Bookmark this page box closes too soon

RESOLVED DUPLICATE of bug 400019

Status

()

RESOLVED DUPLICATE of bug 400019
11 years ago
11 years ago

People

(Reporter: asmodai, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11; .NET CLR 2.0.50727) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11; .NET CLR 2.0.50727) Gecko/20071127 Firefox/2.0.0.11

When trying to add a bookmark through Booksmarks > Bookmark this page if you perform a certain click combination the box closes and registers your bookmark prematurely.

In the same vein, when the box loses focus it will register the bookmark.

Reproducible: Always

Steps to Reproduce:
1. Load a webpage.
2. Open Bookmark this page
3. Click the Folder drop down menu
4. Keep the drop down menu open and click anywhere on the box' chrome

1. Load a webpage
2. Open bookmark this page
3. Click anywhere but the Bookmark this page box
Actual Results:  
Bookmark this page box closes. Bookmark gets filed underneath the Bookmarks menu.

Expected Results:  
The box should not have closed nor should the bookmark have been filed underneath the main Bookmarks menu.

Windows XP SP 3 Release Candidate.
Firefox 3 Beta 2

Comment 1

11 years ago
Your second set of steps to reproduce demonstrates strange but intended behavior.  (See bug 404560, bug 403699, and bug 396513 -- especially the comment from Alex Faaborg in the second bug.)

Your first set of steps to reproduce sounds like bug 400019.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 400019
You need to log in before you can comment on or make changes to this bug.