Browser hangs when accessing a https website with a security certificate.

UNCONFIRMED
Unassigned

Status

()

Core
General
--
minor
UNCONFIRMED
10 years ago
6 years ago

People

(Reporter: Pravesh Pandya, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

I am not sure if this is a bug or not, as I couldn't test this much. I have just tried this out in my machine. 
I connections settings for firefox are the following:
1. A manual proxy which points to proxy server in my intranet.
2. A automatic proxy URL which I use along with my VPN.

Most of the time I am in VPN and hence I am not able to access the intranet sites. The intranet sites can be accessed by the http protocol in the intranet, but while in VPN I need to use the https protocol. 

The problem here is that say if I access a https site using firefox, the browser gets hung. While the same url works fine in IE. I doubt if this is in a way related to the certificate provided by the site. I have faced a similiar problem with some other sites which run on https.

Also another point to be highlighted here is that, say if I am able to access a https site (not necessarily an intranet site, just an internet site which is placed only in the https) in VPN. No say I disconnect from my VPN and switch to the local proxy server, and try to connect to the same https internet site, the browsers gets hung. Again here I doubt this to be a certificate issue. 

I may not be able to share any screenshot or URL with the firefox team as the URL's, VPN connections etc are property of a company where I work. So I would prefer not to share them. Rather if any help is needed from my end I would be glad to offer to the most possible extent. Let me know if you guys need something from me. Let me know if this is not a bug too. May be I am wrong on this. :)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

10 years ago
Component: Security → General
Product: Firefox → Core
QA Contact: firefox → general
Version: unspecified → 1.8 Branch

Comment 1

10 years ago
You also use the same automatic proxy URL in IE then?

Comment 2

6 years ago
I face the same problem.  When a https website (secured) opens, firefox hangs for a couple of seconds.  Minimized firefox does not comes up, normal firefox does not respond to tab switch actions, etc.,  I tried reproducing it in firefox 9 and also in Aurora 11.0a2

I am also behind a proxy server, which is surprisingly a coincidence to this bug.  IE works fine in my case also.  I have set the same proxy server on both browsers.
You need to log in before you can comment on or make changes to this bug.