Having file url in bookmarks destroys directories after migration

VERIFIED FIXED in Future

Status

SeaMonkey
Bookmarks & History
P3
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Jason Kersey, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({helpwanted})

Trunk
Future
x86
Windows NT
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (WinNT; I)
BuildID:    2000052815

I currently have my desktop bookmarked in 4.7.  After migrating, it used to be 
that instead of it being just a normal bookmark, it would actually expand to 
show all the files on the desktop.  Now, not only does it not work, it causes 
all the other folders in that folder to become disfunctional.  For instance:

Current Bookmarks - 

4.7 Example - - - -
*Desktop
*Bookmark
*Bookmark
>Folder
>Folder
>Folder
>Folder

Old Mozilla Example - - - -
>Desktop
*Bookmark
*Bookmark
>Folder
>Folder
>Folder
>Folder

New Mozilla Example- - - -
Desktop
Bookmark
Bookmark
Folder
Folder
Folder
Folder

This may be confusing, so let me explain it.  In 4.x, the desktop book mark is 
just that, a bookmark to a system directory.  In older mozilla builds, that 
bookmark became a folder which held the contents of the desktop.  In new mozilla 
builds, any bookmarks or folders that are in the same folder as a bookmark to a 
system folder bookmark become broken, and do nothing when clicked on.  The 
folders in the folder appear to become bookmarks that don't work.

Reproducible: Always
Steps to Reproduce:
1.bookmark a system folder in 4.x
2.migrate your profile to mozilla
3.go to the folder that the bookmark is in
4.see that all folders and bookmarks appear to be broken

Actual Results:  After bookmarking a folder and migrating, it renders all 
folders and bookmarks unusable

Expected Results:  The folder bookmark should either expand into showing the 
contents of that folder (old mozilla style) or just link to the folder and go to 
it when clicked (4.7).  I loved the way older mozilla builds did it, and would 
love to see that return.

Bookmark a folder freshly in Mozilla without migration seems to work fine.

Comment 1

18 years ago
The migration code just copies the old bookmarks.htm to the new profile 
directory.  The browser itself reads the old bookmarks file and does any 
required conversions.  Reassigning to slamm.
Assignee: dbragg → slamm

Comment 2

18 years ago
changing component/ QA contact
Component: Profile Migration → Bookmarks
QA Contact: gbush → claudius

Comment 3

18 years ago
Reassigning 79 Bookmarks bugs to Ben.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → ben
Netscape Nav triage team: this is not a Netscape beta stopper. adding helpwanted 
to the keywords
Keywords: helpwanted, nsbeta1-

Comment 5

17 years ago
Marking nsbeta1- bugs as future to get off the radar.
Target Milestone: --- → Future
I believe this has been fixed. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.