bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

multiple select menu has long delay for keyboard navigation

RESOLVED DUPLICATE of bug 339541

Status

()

Firefox
Keyboard Navigation
RESOLVED DUPLICATE of bug 339541
11 years ago
11 years ago

People

(Reporter: a.blackthorn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Navigating a multiple select menu using the first letter of each option is nearly impossible.  There is an approx one second period when navigating between items with different first letters during which time the select menu is unresponsive.  This delay is compounded by the fact that each time you press a key during this period, the period resets.

Reproducible: Always

Steps to Reproduce:
1. example HTML
<select multiple size="3">
	<option>A</option>
	<option>B</option>
	<option>C</option>
</select>
2. try toggling options using A, B and C keys
Actual Results:  
Unless you specifically pause after pressing each key, the selected item will not change.

Expected Results:  
The options should change as fast as I can hit the keys, as other browsers do.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 339541
You need to log in before you can comment on or make changes to this bug.