Printing/preview causes deadlock

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: one0db414e7f2e8, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-11-05, URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Trying to print the above wikipedia page causes firefox to "hang", nothing happens any further even after several minutes. In windows task manager I see the memory consumption increase and increase. Since printing is a "modal dialog", all tabs are inaccesible and firefox can only be killed through task manager.

This happens with different printers and even if I only select "print preview". Since this happens on a wikipedia page, this is a really annoying bug. BTW, I can print other wikipedia pages.

Reproducible: Always

Steps to Reproduce:
1.Go to http://de.wikipedia.org/w/index.php?title=Echte_Aloe&printable=yes
2.Press "Druckvorschau" (German for "print preview")
3.
Actual Results:  
Firefox does not respond and must be killed through task manager.

Expected Results:  
Show a preview.

Comment 1

11 years ago
Happens to me on the same page.

Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Comment 2

10 years ago
Do you see it hang with FF3?

WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.2) Gecko/2008091620 Firefox/3.0.2
Keywords: hang
Whiteboard: closeme 2008-11-05

Comment 3

10 years ago
Please try Firefox 3:  http://www.mozilla.com/firefox/
File a new bug if the problem remains.  Thanks for your report.

-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.