Please enable Afrikaans (af) for Thunderbird 2 (MOZILLA_1_8_BRANCH)

VERIFIED FIXED

Status

Thunderbird
Build Config
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Friedel Wolff, Assigned: Pike)

Tracking

({verified1.8.1.12})

verified1.8.1.12

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Afrikaans translations for Thunderbird 2 has been updated (see bug 402054). Please enable it on the branch.
(Reporter)

Comment 1

10 years ago
Created attachment 294338 [details] [diff] [review]
Patch to all-locales to enable Afrikaans (af)

Here is the patch to all-locales to enable Afrikaans, as requested in bug 402054.
Attachment #294338 - Flags: approval1.8.1.12?
(Assignee)

Comment 2

10 years ago
This is a thunderbird proper bug, moving over there.

Friedel, did you try a pristine check-out from cvs with this patch applied?

Please request review on this patch before requesting approval, too, either from me or from bsmedberg (:bs completes).

Sorry for not flipping all switches, I'm on slow-holidays mode.
Assignee: dwayne → nobody
Component: af / Afrikaans → Build Config
Product: Mozilla Localizations → Thunderbird
QA Contact: dwayne → build
Version: unspecified → 2.0
(Reporter)

Comment 3

10 years ago
Comment on attachment 294338 [details] [diff] [review]
Patch to all-locales to enable Afrikaans (af)

Asking for review as requested by Axel
Attachment #294338 - Flags: review?(l10n)
(Reporter)

Comment 4

10 years ago
Thanks for moving the bug to the correct place. I also only returned from holiday today. Yes, the patch applies to current MOZILLA_1_8_BRANCH. (The last change was long ago: 2007/03/08 17:29:56,  bug 372145)
(Assignee)

Comment 5

10 years ago
Back from vacation, taking this bug.
Assignee: nobody → l10n
(Assignee)

Comment 6

10 years ago
Comment on attachment 294338 [details] [diff] [review]
Patch to all-locales to enable Afrikaans (af)

r=me, a=me for enabling thunderbird builds on the branch.
Attachment #294338 - Flags: review?(l10n)
Attachment #294338 - Flags: review+
Attachment #294338 - Flags: approval1.8.1.12?
Attachment #294338 - Flags: approval1.8.1.12+
(Assignee)

Comment 7

10 years ago
Landed on branch.

Checking in all-locales;
/cvsroot/mozilla/mail/locales/all-locales,v  <--  all-locales
new revision: 1.15.2.10; previous revision: 1.15.2.9
done

Friedel, please verify the builds on all three platforms and give them all the QA your community can offer.

Do we have a dedicated tb2 af shipping bug yet?
Keywords: fixed1.8.1.12
(Reporter)

Updated

10 years ago
Blocks: 413914
(Reporter)

Comment 8

10 years ago
I created the shipping bug. See bug 413914. Nightly builds were done, so can this bug now be closed?
(Assignee)

Comment 9

10 years ago
Yes, let's close it. Mind following up in the shipping bug with a comment on which platforms you tested?
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Verified. We build Afrikaans for the TB 2.0.0.12 release.
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1.12 → verified1.8.1.12
Created attachment 305817 [details]
Potential Afrikaans menu issue

I see this partially unlocalized menu in the Afrikaans build. Is this by-design?

This is on OS X 10.5.2.
Reopening pending resolution of comment #11.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Keywords: verified1.8.1.12 → fixed1.8.1.12
QA Contact: build → build-config

Comment 13

10 years ago
(In reply to comment #11)
> Created an attachment (id=305817) [details]
> Potential Afrikaans menu issue
> 
> I see this partially unlocalized menu in the Afrikaans build. Is this
> by-design?

Definitely not by design.  The only references I can find for those strings is in: en-US/browser/chrome/browser/baseMenuOverlay.dtd:<!ENTITY hideOtherAppsCmdMac.label      "Hide Others">

This is in the browser/ sub-directory which was unexpected.  We are busy investigating.

Comment 14

10 years ago
CVS tag shows that l10n/af/browser/chrome/browser/baseMenuOverlay.dtd exists and is tagged THUNDERBIRD_2_0_0_12_RELEASE (1.1.2.2) and MOZILLA_1_8_BRANCH
(In reply to comment #13)
> Definitely not by design.  The only references I can find for those strings is
> in: en-US/browser/chrome/browser/baseMenuOverlay.dtd:<!ENTITY
> hideOtherAppsCmdMac.label      "Hide Others">
> 
> This is in the browser/ sub-directory which was unexpected.  We are busy
> investigating.
> 
Actually it's by OS X design. Please take a look at Bug 410658 comment #21  
(Assignee)

Comment 16

10 years ago
Resolving again, see further discussion in bug 410658.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1.12 → verified1.8.1.12
You need to log in before you can comment on or make changes to this bug.