js error opening Popup Manager or Help menu

RESOLVED FIXED in seamonkey2.0a1

Status

SeaMonkey
UI Design
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: stefanh, Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
seamonkey2.0a1
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Tools --> Popup Manager or just opening the Help menu will result in this js error:

Error: popups is null
Source File: chrome://communicator/content/utilityOverlay.js
Line: 696

Probably bug 393120
(Assignee)

Comment 1

10 years ago
Created attachment 294388 [details] [diff] [review]
Proposed patch

We use a null-check rather than a length-check everywhere else.
Assignee: guifeatures → neil
Status: NEW → ASSIGNED
Attachment #294388 - Flags: review?(stefanh)
(Reporter)

Comment 2

10 years ago
Comment on attachment 294388 [details] [diff] [review]
Proposed patch

JFTR the error from opening the Help menu probably just happens on Leopard. I asked Neil about it and it just hit me that on Leopard, there's a built-in search box in the Help menu that might be the cause of the error seen in the js consle.
Attachment #294388 - Flags: review?(stefanh) → review+
(Reporter)

Updated

10 years ago
Target Milestone: --- → seamonkey2.0alpha
(Assignee)

Comment 3

10 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.