<INPUT TYPE="img"> draws with border unless BORDER attribute specified as 0

RESOLVED INVALID

Status

()

P3
normal
RESOLVED INVALID
19 years ago
18 years ago

People

(Reporter: jsp, Assigned: rods)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m16) Gecko/20000529
BuildID:    2000052908

Image inputs on forms draw with a border unless BORDER=0. HTML 4.0 makes
provision for no such attribute.  I won't speculate as to the wisdom of
including non-standard attributes, but if they are added, they should default to
values that cause behavior consistent with an implementation that does not have
such "extensions" (in this case, zero).	

Reproducible: Always
Steps to Reproduce:
Put the following HTML in a file:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">
<HTML>
<HEAD>
<BODY>
<FORM>
<INPUT TYPE="image" SRC="http://www.mozilla.org/images/mozilla-banner.gif" />
<P />
<INPUT BORDER="0" TYPE="image" SRC="http://www.mozilla.org/images/mozilla-
banner.gif" />
</FORM>
</BODY>
</HTML>

Bring the file up in Mozilla.

Actual Results:  The first "button" has a border around it (because we haven't
said we didn't want one); the second displays without a border.


Expected Results:  Both buttons should have displayed without a border.

Web page authors can obviously work around this easily, but they shouldn't have
to.  I'm a bit puzzled by this behavior, which appears to be a holdover from
earlier versions of Navigator.  I'd understood Gecko to be a clean break.
(Assignee)

Comment 1

19 years ago
This is a NavQuirks issue that is known. We will soon have a NavQuirks 
stylesheet and a Standard (or Strict) stylesheet. It will have the border in 
NavQuirks, but not in Standard or Strict mode.

marking as invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 2

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma
You need to log in before you can comment on or make changes to this bug.