Status

()

Firefox
General
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Robin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2007122204 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2007122204 Minefield/3.0b3pre

The areas with flash comes on top and covers the "floating! menu bar which should be on top.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
A few Flash objects are on the page without beeing set to windowless,that means they are always on top. 
Example:
<embed src="http://www.dailymotion.com/swf/uMqIJf0sZse8FpogB" type="application/x-shockwave-flash" allowfullscreen="true" height="400" width="430">

and then you are on linux where windowless support is only in the latest builds and where Macromedia must add windowless support in their Linux flash plugin.

BTW If you report something about a plugin, alwas include the used plugin version
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

11 years ago
Flash version is 9.0 r48.

So this is fixed for windows now? Because I remember it being a problem the last time i used Minefield on win. But that was a couple of months ago. Anyway I don't really get why it functions as it should in FF2 and not in Minefield but then again I'm nu developer.
It works on windows since a long time (years)
I used your URL, scrolled down and one of the flash movies overlapped the menu but that is because of a code error on the side (missing wmode parameter, see the my comment above).

On Linux this is only fixed in the latest builds (bug 137189) but it has to be also fixed in the flash plugin itself. It could be already fixed in the latest flash player for linux (9.0 r115 is the latest for win32). Old player or Gecko Build = The flash is always on top on everything.
from https://bugzilla.mozilla.org/show_bug.cgi?id=137189#c107 :
It still not fixed in 9.0 R115 on linux
(Reporter)

Comment 5

11 years ago
Ok so it looks like the problem is acknowledged. Thats nice! I hope the flash plugin will be fixed before FF3 is released so people don't see this as their first impression. 
You need to log in before you can comment on or make changes to this bug.