Closed Bug 409616 Opened 12 years ago Closed 12 years ago

Extension icon is not updated when you do a change icon from the edit Add-on page

Categories

(addons.mozilla.org Graveyard :: Developer Pages, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: wgianopoulos, Assigned: fligtar)

References

Details

Changing an add-on icon from the Edit Add-on page does not seem to work.  The new icon seems to be saved to /en-US/firefox/images/addon_icon/xxxx/<random number>.  However, the displayed icon seems to omit the <random number> part of the url.  It appears that once you set an icon you can either clear it or go back to the original.  Uploading a completely different icon seems to revert to displaying the original.

I am seeing this in the sandbox for add-on 5460.

I ran into bug 381977 and tried to replace the icon with one that did not use transparency and do not seem to be able to do it.
Component: Admin/Editor Tools → Developer Pages
QA Contact: admin-tools → developers
Blocks: 430189
Target Milestone: --- → 3.5
Assignee: nobody → fligtar
This bug has been fixed on the AMO 3.5 Developer Tools revamp branch and will go live when 3.5 is launched (date not currently set).

There is a staging site available here: http://remora-3.5.php5stage.mozilla.com/en-US/firefox/
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
This is nearly instantaneous, but can take a few reloads to take effect, both in the dev CP and on the display page, but I think I'm hitting bug 425315, since I know that http://remora-3.5.php5stage.mozilla.com/en-US/firefox/ is behind the Citrix Netscalers, and probably behind memcache too?

Not sure if I should wait until bug 425315 is fixed to verify this or not, then.
Verified FIXED; I think fligtar's change to not using memcache on this page made the difference now:

https://remora-3.5.php5stage.mozilla.com/en-US/developers/addon/edit/7522/properties
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.