Closed Bug 409636 Opened 12 years ago Closed 12 years ago

autocomplete-richlistitem binding creates superfluous vbox

Categories

(Toolkit :: XUL Widgets, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9beta3

People

(Reporter: dao, Assigned: dao)

References

Details

Attachments

(2 files)

Attached patch patchSplinter Review
No description provided.
Attachment #294428 - Flags: review?(neil)
Attached patch patch (diff -w)Splinter Review
Comment on attachment 294428 [details] [diff] [review]
patch

Surely, as it relates to the binding, this style belongs in xul.css?
I don't think so, because the vertical layout that was chosen (as opposed to the horizontal one for the old location bar) doesn't seem to be a requirement of the binding.
In fact, people are already discussing CSS hacks for making the layout horizontal again, so I think giving theme authors full control from the start is a good thing.
Attachment #294428 - Flags: review?(neil) → review+
Attachment #294428 - Flags: approval1.9?
Dao risk/reward for this?
The reward is that we create one less element for each autocomplete entry in the Location Bar. That won't be a noticeable win; there are other far more expensive things. I had tested the patch on Windows before attaching it and as far as I can tell, there's no risk.
Comment on attachment 294428 [details] [diff] [review]
patch

thnx Dao!
Attachment #294428 - Flags: approval1.9? → approval1.9+
Checking in toolkit/content/widgets/autocomplete.xml;
/cvsroot/mozilla/toolkit/content/widgets/autocomplete.xml,v  <--  autocomplete.xml
new revision: 1.104; previous revision: 1.103
done
Checking in toolkit/themes/pinstripe/global/autocomplete.css;
/cvsroot/mozilla/toolkit/themes/pinstripe/global/autocomplete.css,v  <--  autocomplete.css
new revision: 1.17; previous revision: 1.16
done
Checking in toolkit/themes/winstripe/global/autocomplete.css;
/cvsroot/mozilla/toolkit/themes/winstripe/global/autocomplete.css,v  <--  autocomplete.css
new revision: 1.25; previous revision: 1.24
done
Status: NEW → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M11
heads up, this caused a regression on the mac, see bug #410882.
> heads up, this caused a regression on the mac, see bug #410882.

my apologies to Dao, I'm not able to reproduce that bug anymore, so I've marked it invalid.
You need to log in before you can comment on or make changes to this bug.