Autodial: canceling connection for local page w/ remote image

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
critical
VERIFIED WORKSFORME
18 years ago
15 years ago

People

(Reporter: kirun, Assigned: rpotts (gone))

Tracking

({crash})

Trunk
x86
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
To reproduce:

1) Make sure you're not connected to the internet

2) Open a locally stored page with a link to an online image

3) Click "cancel" on dialup connection request

This always crashes 2000052508
(Reporter)

Comment 1

18 years ago
Created attachment 9310 [details]
View this *offline* to see bug

Comment 2

18 years ago
Can't test right now, but setting severity to critical, adding crash kw.
Severity: normal → critical
Keywords: crash

Comment 3

18 years ago
Created attachment 9423 [details]
stack trace on PC/Linux, build 2000052908

Comment 4

18 years ago
Confirming bug on PC/Linux. I saved the attachment to a local file
"offline.html", rebooted standalone, ran mozilla, and entered the file name in
the location bar. After pressing return mozilla segfaults:

#0  0x40091e59 in nsXPIDLString::nsXPIDLString ()   from libxpcom.so
#1  0x40092cb8 in nsXPIDLString::nsXPIDLString ()   from libxpcom.so
#2  0x40092f30 in nsTextFormatter::vsmprintf ()     from libxpcom.so
#3  0x40092ec8 in nsTextFormatter::smprintf ()      from libxpcom.so
#4  0x40951d8d in nsWebShell::OnEndDocumentLoad ()  from libraptorwebwidget.so

Changing OS to All. Needs to be reassigned.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 95 → All

Comment 5

18 years ago
Trying Networking component because this is an "offline" bug. CC self.
Assignee: asa → gagan
Component: Browser-General → Networking
QA Contact: jelwell → tever
(Reporter)

Comment 6

18 years ago
This doesn't seem to happen on 2000060808 (win95).
(Reporter)

Comment 7

18 years ago
To avoid confusion, when I said "offline" , I meant not connected to the
Internet, not in offline mode.

Although this now doesn't crash the browser, it still causes problems. The best
behaviour would be to give an option to go into offline mode, or retry
connecting to the Internet.


As OS is "All" I don't want to mark as "fixed" because I only have access to a
win95 machine.
(Reporter)

Comment 8

18 years ago
I have found why the browser has not crashed with this recently (at least on my
system). It seems all the images had cached copies. The crash seems to occur
when there is no cached copy.

Comment 9

18 years ago
I think I have seen a dup of this in the webshell/uriloader land. over to 
rpotts. 
Assignee: gagan → rpotts

Comment 10

18 years ago
gordon, any thoughts?
Target Milestone: --- → M18

Comment 11

18 years ago
I cannot reproduce this with 10/16 window branch build. I try the following
1. I download the attachment.
2. I change to attachment to point to another image which does not exist.
3. I unplug the ethernet from my computer
4. I load my local page.
It won't crash now.

kieran_1@yahoo.com- can you still reproduce the crash? If not, can we take out
the crash from the keyword ?

Comment 12

18 years ago
I try the same procedure above on recent Linux build. The moment I unplug my
Ethernet cable, Mozilla freeze. So... I cannot reprudce the problem . After I
plugin it back, it run.... I think that is a seperate issue.
(Reporter)

Comment 13

18 years ago
I am currently unable to reproduce the crash. (2000101804 on win95). I'll post a
trace if I can get it to happen again.
(Reporter)

Comment 14

18 years ago
This crash may be related: (talkback TB19569208H)

I had two open windows, both marked as being offline, and I was not connected to 
the Internet. I opened a copy of the CSS1 spec, which has references to some 
files on the w3c site. No dialup attempt, just a crash.

Build ID: 2000102108

MOZILLA caused an invalid page fault in
module <unknown> at 0000:00c9ad82.
Registers:
EAX=00c9ad81 CS=014f EIP=00c9ad82 EFLGS=00010206
EBX=00cbdaf0 SS=0157 ESP=0068e404 EBP=0068e418
ECX=01adb148 DS=0157 ESI=80000000 FS=488f
EDX=00000002 ES=0157 EDI=00000000 GS=0000
Bytes at CS:EIP:
ad 01 48 b1 ad 01 01 00 00 00 f0 f2 c9 00 00 00 
Stack dump:
015fdf88 00c9ad80 00000000 80000000 00c9ad80 0068e46c 0160ae29 0068e450 00c9a8f0 
00c9f2f0 00000000 01ff34e0 00000000 00000200 00000000 00000000 

Updated

18 years ago
Target Milestone: M18 → ---

Comment 15

17 years ago
marking WFM. please re-open if we have a reproducible test case.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 16

17 years ago
reporter:

This bug is a "futured" or "untargeted" bug which has been "resolved/works for
me". Most bugs meeting this criteria are usually somewhat out of date or working
in the current builds.

If this bug is not happening for you in a recent build (such as the Mozilla
daily build, Mozilla 0.9.3, or Netscape 6.1), please use the friendly "Mark bugs
as VERIFIED" radio button to set this bug to "VERIFIED/WORKS FOR ME"
If you reported the bug on a platform (e.g. Linux) and other contributors
reported on another platform (e.g. Mac OS), please comment that it works for you
 but do not verify it yet.

For these multi-platform bug reports, we need to verify all reported platforms
-OR- create new "still broken on platform X" bugs when you verify.
(Reporter)

Comment 17

17 years ago
Just tested it. No crash on Windows 95 (2001092908)

Updated

16 years ago
QA Contact: tever → benc

Comment 18

15 years ago
VERIFIED: WFM, per reporter.

Andreas, if you can still see this, please REOPEN.
Status: RESOLVED → VERIFIED
Summary: crash when viewing page with online image and not connecting → Autodial: canceling connection for local page w/ remote image
You need to log in before you can comment on or make changes to this bug.