Firefox fails to display any pages within www.facebook.com properly

VERIFIED INCOMPLETE

Status

()

Firefox
General
--
major
VERIFIED INCOMPLETE
10 years ago
7 years ago

People

(Reporter: Zee Wilyanto, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Any pages displayed within www.facebook.com have a blue background (usually it is white). And the icons and arrangements within these pages are messed up too. There are no problems displaying all other web pages. However, these pages that failed to be displayed properly can be displayed in the usual manner using Internet Explorer. Attached will be the images of the same page showed by the 2 browsers. I have never had this problem until today. Please fix it asap. I tried uninstalling my firefox and reinstall the latest firefox but the problem still persists. (Erm, I cannot find any place to attach images of the problem (i printed the screen), please email me if you need the pics)

Reproducible: Always

Steps to Reproduce:
1.go to www.facebook.com using the firefox browser
2.
3.
Actual Results:  
the page is not displayed correctly. the color is wrong and the icons/arrangements of the icons are wrong too.

Expected Results:  
it should have displayed the page normally.

i'm using the pink paula theme
A screenshot how it looks for you and how it should look would be something that you should add to a bug report. Did you also test it in the Firefox safemode ?
And for broken sites we have usually the Firefox menue entry "report broken site", you have here to add a minimized testcase if you really think this is a bug in Firefox and you want to get it fixed.

Comment 2

9 years ago
Created attachment 386813 [details]
Facebook page.

This is how facebook home page or any other page looks like.

Comment 3

9 years ago
**The above attachment was from me.


Hello guys/girls =)

Just thought of giving a heads up, I may have similar problems with facebook page loading.

I am currently using firefox 3.5 and windows XP. 

Facebook doesn't load properly at infrequent time, but it sometimes do. And no, I haven't test it in the safe mode.

1. I've posted the screenshot above. =)

2. Below is the lines of codes from the error console (Hope this helps):

-------------------------------------------------------

This is from the error console 


Error: Bootloader.loadInitialResources is not a function
Source File: http://www.facebook.com/home.php?ref=home
Line: 23
-------------------------------------------------------

This is what I got After evaluation:

Error: missing ; before statement
Source File: javascript:%20Error:%20Bootloader.loadInitialResources%20is%20not%20a%20function%20Source%20File:%20http://www.facebook.com/home.php?ref=home%20Line:%2023
Line: 1, Column: 19
Source Code:
 Error: Bootloader.loadInitialResources is not a function Source File: http://www.facebook.com/home.php?ref=home Line: 23

-------------------------------------------------------

This is from the source page:

<script type="text/javascript">Bootloader.loadInitialResources([{"name":"js\/duyxoi22mzccw8k0.pkg.js","type":"js","src":"http:\/\/static.ak.fbcdn.net\/rsrc.php\/z600M\/lpkg\/79b28w70\/en_US\/141\/172224\/js\/duyxoi22mzccw8k0.pkg.js","permanent":false},{"name":"js\/5gkxh7ddngsocgog.pkg.js","type":"js","src":"http:\/\/b.static.ak.fbcdn.net\/rsrc.php\/zAYRG\/lpkg\/ac49oggl\/en_US\/141\/172410\/js\/5gkxh7ddngsocgog.pkg.js","permanent":false},{"name":"js\/6t99vbwpdu8s80oo.pkg.js","type":"js","src":"http:\/\/b.static.ak.fbcdn.net\/rsrc.php\/z29KY\/lpkg\/7p8y2chf\/en_US\/141\/171165\/js\/6t99vbwpdu8s80oo.pkg.js","permanent":false},{"name":"js\/bd92cz7b1og0kkss.pkg.js","type":"js","src":"http:\/\/static.ak.fbcdn.net\/rsrc.php\/z8C2I\/lpkg\/bat6l02s\/en_US\/141\/167919\/js\/bd92cz7b1og0kkss.pkg.js","permanent":false},{"name":"js\/home.js","type":"js","src":"http:\/\/static.ak.fbcdn.net\/rsrc.php\/zBDIN\/l\/89exqwhl\/en_US\/164661\/js\/home.js","permanent":false},{"name":"js\/dq2hvbqq01s0ok4o.pkg.js","type":"js","src":"http:\/\/b.static.ak.fbcdn.net\/rsrc.php\/zZZ2H\/lpkg\/2yionnr8\/nu_ll\/141\/170999\/js\/dq2hvbqq01s0ok4o.pkg.js","permanent":false},{"name":"js\/chpyi0cgglwsw0sw.pkg.js","type":"js","src":"http:\/\/b.static.ak.fbcdn.net\/rsrc.php\/z429R\/lpkg\/8trl0vwf\/en_US\/141\/172251\/js\/chpyi0cgglwsw0sw.pkg.js","permanent":false},{"name":"js\/4bno4b8k998ggc8g.pkg.js","type":"js","src":"http:\/\/b.static.ak.fbcdn.net\/rsrc.php\/z13U4\/lpkg\/7y8uz1kf\/nu_ll\/141\/167952\/js\/4bno4b8k998ggc8g.pkg.js","permanent":false},{"name":"js\/7efg46w6akwsow4g.pkg.js","type":"js","src":"http:\/\/static.ak.fbcdn.net\/rsrc.php\/z6WWK\/lpkg\/2k6b3q0p\/en_US\/141\/172401\/js\/7efg46w6akwsow4g.pkg.js","permanent":false},{"name":"js\/emntp0wp22gw4084.pkg.js","type":"js","src":"http:\/\/static.ak.fbcdn.net\/rsrc.php\/z4VPZ\/lpkg\/7ejqks0j\/en_US\/141\/172176\/js\/emntp0wp22gw4084.pkg.js","permanent":false},{"name":"js\/1qyd79nvbnogocw8.pkg.js","type":"js","src":"http:\/\/static.ak.fbcdn.net\/rsrc.php\/zDBOU\/lpkg\/2jcawtwv\/en_US\/141\/168166\/js\/1qyd79nvbnogocw8.pkg.js","permanent":false},{"name":"js\/emu\/sampling.js","type":"js","src":"http:\/\/b.static.ak.fbcdn.net\/rsrc.php\/zD0C7\/l\/7f2tznny\/nu_ll\/172251\/js\/emu\/sampling.js","permanent":false},{"name":"js\/s71agrnn1iosks4o.pkg.js","type":"js","src":"http:\/\/static.ak.fbcdn.net\/rsrc.php\/z4P3R\/lpkg\/6v87mudz\/en_US\/141\/172157\/js\/s71agrnn1iosks4o.pkg.js","permanent":false},{"name":"js\/afdhsu2odxc048cc.pkg.js","type":"js","src":"http:\/\/static.ak.fbcdn.net\/rsrc.php\/z126Q\/lpkg\/6akdosvy\/en_US\/141\/171709\/js\/afdhsu2odxc048cc.pkg.js","permanent":false},{"name":"js\/f051yxtp6i0owg0o.pkg.js","type":"js","src":"http:\/\/static.ak.fbcdn.net\/rsrc.php\/zCUKA\/lpkg\/d31u9nen\/en_US\/141\/168792\/js\/f051yxtp6i0owg0o.pkg.js","permanent":false}])</script>


-------------------------------------------------------


Am not sure if the problem is due to firefox or because facebook is currently working on its site upgrades.

Hope my report doesn't waste you guys time.

Really appreciate the effort you guys are doing.

Comment 4

9 years ago
i couldnt get FB to work either until i downloaded the user agent switcher...now everything works fine again...
The report is from 2006 and the reporter never answered -> incomplete.

>i couldnt get FB to work either until i downloaded the user agent
>switcher...now everything works fine again...

That can only mean that the issue depends on the UA string and that can't be a Firefox bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.