If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add a non-cookie-based method of logging in to the WebService

RESOLVED DUPLICATE of bug 389986

Status

()

Bugzilla
WebService
--
enhancement
RESOLVED DUPLICATE of bug 389986
10 years ago
8 years ago

People

(Reporter: Max Kanat-Alexander, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
In some XML-RPC clients, it's difficult to use Cookies.

We should provide a method of logging in that doesn't require using Cookies.

I was thinking that User.login could return a login_token and we could pass login_token and login_id as arguments to every WebService function that requires a login. Bugzilla::WebService could intercept those parameters and do a login appropriately.

Possibly this could be implemented as Bugzilla::Auth::Login::WebService, and we could append it to the login methods in Bugzilla::Auth->new if we're in USAGE_MODE_WEBSERVICE.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389986
You need to log in before you can comment on or make changes to this bug.