If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Address and Search fields should lose focus on pressing Esc

VERIFIED INVALID

Status

Camino Graveyard
Accessibility
--
enhancement
VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: Sergei Yakovlev, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/523.12.1 (KHTML, like Gecko) Version/3.0.4 Safari/523.12.2
Build Identifier: Version 2007112812 (1.5.4)

Currently, pressing Command-L takes focus to the address field, and pressing Shift-Command-F takes focus to the search field. It should be possible to remove focus from these fields. While it is certainly possible by clicking with the mouse somewhere on the page, there should be a keyboard equivalent. One can press Shift-Tab in the address field or Tab in the search field, but it is somewhat clumsy because it was designed for tabbing between the fields on the page. It would be much more obvious and consistent if the address and search fields would lose focus on pressing Escape.

Reproducible: Always

Comment 1

10 years ago
Where would the focus be expected to land at that point? Leaving nothing in the window focused isn't at all standard (or desirable) behavior.

> it is somewhat clumsy because it was designed for tabbing between the fields
> on the page.

I'm not sure what this means. Tabbing through fields is an convention across the entire OS, not something that was invented for web pages.
(Reporter)

Comment 2

10 years ago
I am sorry for being too quick to post this issue. What I initially proposed is actually against the Mac OS X conventions, at least for the Search field. In standard applications like Safari, Mail, Address Book and iTunes, pressing Escape while in the search field clears it while retaining focus (instead of retaining content and losing focus like I have proposed). As this is probably the built-in functionality of NSSearchField control, it should already be fixed on trunk by 330666. Again, I apologize for giving this issue little thought.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.