Default Home Page should be blank

VERIFIED WONTFIX

Status

Camino Graveyard
General
--
enhancement
VERIFIED WONTFIX
11 years ago
11 years ago

People

(Reporter: Sergei Yakovlev, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/523.12.1 (KHTML, like Gecko) Version/3.0.4 Safari/523.12.2
Build Identifier: 

Currently Camino uses http://www.mozilla.org/projects/camino/homepage.html as its default home page, which redirects to http://caminobrowser.org/start/, which contains a link to the http://caminobrowser.org/ and a Google search field. There's already a Google search field in the top right corner of the browser window, and the website for Camino is easily accessed via Help > Camino Home Page. Why the need for this home page? It is completely redundant and it is even abusing the user, because each time she opens a new window, she has to wait for this page to load. Most users grow tired of this delay and set the home page to blank. Some inexperienced users may not even know about the preference and thus continue to suffer. Most users change the home page to blank or to some other page, so the default value should be blank.

The whole 'home page' thing started because browser vendors wanted to maximize user visits to their 'portal' web sites so they could profit from advertising. The times have changed. Now, there's no need for default home page, it's time to make it blank. (On a side note, this might mark the end of the Home Page as people will start using bookmark bar or auto-complete for frequently-visited locations.)

Reproducible: Always

Comment 1

11 years ago
Personal rant?

Invalid?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

11 years ago
Your assertion that "most" users want a blank home page is simply not true. Moreover, there is a set of inexperienced users who would be very confused, and conclude that Camino didn't work at all, if we showed nothing on launch (we have concrete data on this based on feedback we received during an outage of caminobrowser.org.

If you don't want a home page, you are free to change your preferences, but the default is not going to be blank. WONTFIX.

(Derek, please don't confirm requests that are obviously controversial; we prefer to keep them UNCONFIRMED until a decision has been made one way or the other.)
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX

Comment 3

11 years ago
Opps sorry didn't notice the change to status, must have accidentally clicked something on my way down to submit button.

I didn't intend to change that.
You need to log in before you can comment on or make changes to this bug.