Closed Bug 409721 Opened 15 years ago Closed 15 years ago

Password changed without any "Are you sure ?" prompt

Categories

(Toolkit :: Password Manager, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 408797

People

(Reporter: philsdream, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

This mishap arrived to my neighbor and to my wife who are newbies in PC use.

Using the password data base by entering the general password. 
If, by error you overwrite the password given by the database and if you make a mistake, this false password is recorded in the database without any warning, and now your database is wrong. Your password is lost !!!

Please warn in such a case "ARE YOU SURE YOU WANT TO CHANGE THE PASSWORD ?"



Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Merry Christmas with all
I don't really understand what the problem is. You have to type the password twice, so you can't accidentally change it. A confirmation dialog is possible, but might be considered superfluous by some people.

If you lost your master password, you can always reset it, see <http://kb.mozillazine.org/Master_password>.
So, the original thinking here is that confirmation dialogs are a pain in normal use, because they constantly interrupt you. So while there's a small chance we might change a password you didn't really want changed, it's an overall win because we're not being annoying in the common case.

Bug 394611 suggests using notification bars as a way to still have a prompt, but in a less-annoying way. Bug 408797 was spun off from that, specifically for the change-password case,
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408797
@ Justin Dolske,

I agree completely with you but, in this precise case, the use is abnormal thus in the majority of the cases you will not have a dialog box. 

This being known as, it is completely abnormal to be able to modify the database thus. 

For me, the best possible correction of this problem is to prohibit the modification in this way. 

In order to modify a password, it would be preferable to access your password list and to have a button making it possible to modify a line.

Merry Christmas.

Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.