If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Wrong version number on 2.0.0.6 -> 2.0.0.11 upgrade path

RESOLVED WORKSFORME

Status

Release Engineering
General
RESOLVED WORKSFORME
10 years ago
4 years ago

People

(Reporter: justdave, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

I discovered one of our Windows boxes had Firefox 1.5.0.4 on it today.  The Help menu said it was downloading 1.5.0.11.  So I picked it and let it finish downloading then restarted into it.  It then offered me 1.5.0.12.  I installed that.  Then it offered me 2.0.0.6.  I installed that.  Then it offered me 2.0.0.9.  I installed that.  Except then I discovered what I'd just installed was 2.0.0.11 not 2.0.0.9, so the text on the update available box was wrong.
Assignee: morgamic → nobody
Component: General → Build & Release
Product: AUS → mozilla.org
QA Contact: general → build
Version: 2.0 → other
The server seems to be returning the correct version string for Fx 2006 win32 en-US:

https://aus2.mozilla.org/update/2/Firefox/2.0.0.6/2007072518/WINNT_x86-msvc/en-US/release/null/update.xml

--
<updates>
  <update type="minor" version="2.0.0.11"
--
Dave, can you attach updates.xml from this machine ? On Win2003, I think you want the one in
  C:\Documents and Settings\<username>\Local Settings\Mozilla\Firefox
but please check the timestamp for sanity (otherwise the updates.xml in app install dir).
Created attachment 294585 [details]
updates.xml

This is the only updates.xml file I could find on the whole computer.  It was located in C:\Program Files\Mozilla Firefox
Hmm, that's 1.5.0.1 --> 1.5.0.12, by the looks. Did your search include hidden folders ? Local Settings is that way inclined.
I might have been on the wrong box...  there's two windows boxes I was playing with at the time (the two backend talkback servers) and I didn't remember which one it was.  That box actually has FF 1.5.0.11 on it still, so it must have been the other one, but I can't get into it again now.  I can try to reproduce on this one again. :)
Hey Dave, were you able to reproduce this again?
Please reopen if this is reproducable; works for me.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.