bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Dragging favicon to desktop fails to save properly url with some non-english languages

VERIFIED FIXED in Firefox 3

Status

()

Firefox
General
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: Emil Ivanov, Assigned: dao)

Tracking

({intl, regression})

Trunk
Firefox 3
x86
Windows XP
intl, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [RC2+], URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2007122505 Minefield/3.0b3pre

Its strange that when i drag the address from the url bar it fails, but if i drag link with the same address from the page its saved correctly.

Reproducible: Always

Steps to Reproduce:
1. Open the url above
2. Drag it to desktop
3. Open the file
(Reporter)

Updated

11 years ago
Summary: Dragging favicon or tab to desktop fails to save properly url with cyrillic letters → Dragging favicon or tab to desktop fails to save properly url with some non-english languages
(Reporter)

Comment 1

11 years ago
Not working with Cyrillic and also with Arabic, Greek, Hebrew
(Reporter)

Updated

10 years ago
Keywords: intl

Comment 2

10 years ago
ccing shawn for the url bar

Comment 3

10 years ago
sorry, i wanted to cc edward! :)
Dragging the provided url's favicon from the location bar results in a file with:

http://bg.wikipedia.org/wiki/0G0;=0_AB@0=8F0
(Assignee)

Updated

10 years ago
Component: Places → General
QA Contact: places → general
(Assignee)

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: Dragging favicon or tab to desktop fails to save properly url with some non-english languages → Dragging favicon to desktop fails to save properly url with some non-english languages
(Assignee)

Comment 5

10 years ago
Created attachment 321808 [details] [diff] [review]
patch
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #321808 - Flags: review?(gavin.sharp)
(Assignee)

Updated

10 years ago
Version: unspecified → Trunk
(Assignee)

Comment 6

10 years ago
As a documented feature, I think we should fix this in 3.0 or 3.0.1...

http://support.mozilla.com/en-US/kb/Creating+a+desktop+shortcut+to+a+web+page
Flags: wanted1.9.0.x?
Whiteboard: [RC2?]
Comment on attachment 321808 [details] [diff] [review]
patch

I don't really understand what the various flavors are used for (presumably text/x-moz-url is the relevant one here?), but I assume this just reverts to the Firefox 2 behavior of using the escaped URL. The less common case of having a modified URL bar when dragging probably isn't worth worrying about (the favicon is related to the current site anyways).
Attachment #321808 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 8

10 years ago
(In reply to comment #7)
> (From update of attachment 321808 [details] [diff] [review])
> I don't really understand what the various flavors are used for (presumably
> text/x-moz-url is the relevant one here?), but I assume this just reverts to
> the Firefox 2 behavior of using the escaped URL.

text/x-moz-url is used for the desktop
text/unicode is used by simple text editors
text/html is used by rich text editors

> The less common case of having
> a modified URL bar when dragging probably isn't worth worrying about (the
> favicon is related to the current site anyways).

Dragging won't work if the value is modified since PageProxyDragGesture() checks for pageproxystate=="valid".
(Assignee)

Updated

10 years ago
Attachment #321808 - Flags: approval1.9?

Comment 9

10 years ago
FYI, this seems to work fine on MacOS.  Dragging the URL to the desktop and then opening it from the desktop works great.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008052104 Minefield/3.0pre

Comment on attachment 321808 [details] [diff] [review]
patch

a=beltzner, please land ASAP on cvsroot
Attachment #321808 - Flags: approval1.9? → approval1.9+
Whiteboard: [RC2?] → [RC2+]
(Assignee)

Updated

10 years ago
Keywords: checkin-needed
mozilla/browser/base/content/browser.js 	1.1033 
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3
Flags: wanted1.9.0.x?

Comment 12

10 years ago
Favicon drag works fine now on XP. I tried it on RC2 and nightly. 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008060306 Minefield/3.0pre

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

One question, though: Is dragging the URL (not the favicon) to the desktop suppose to create a file as well? 

I ask because that does not work, but the favicon drag does.
(Assignee)

Comment 13

10 years ago
(In reply to comment #12)
> One question, though: Is dragging the URL (not the favicon) to the desktop
> suppose to create a file as well?

No.

Comment 14

10 years ago
Ok then this is confirmed for RC2 and nightly.
(Assignee)

Comment 15

10 years ago
Ok, thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.