CNN Video page asks for CSS to be turned on

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P3
normal
VERIFIED FIXED
18 years ago
3 years ago

People

(Reporter: Cyril Bortolato, Assigned: bc)

Tracking

({top100})

Details

(URL)

(Reporter)

Description

18 years ago
To reproduce: go to the above URL.
(this is the "CNN video" link on CNN home page)

Actual results:
I get a black page with the message:

CNN Videoselect requires Cascading Style Sheets.
Please turn them on in your preferences.

And then another page (cnn.com/video_vault) loads.
(is there a pref in mozilla to turn CSS on/off?)

With NN 4.7, cnn.com/videoselect page loads fine.

Expected results:
Mozilla supports CSS so I should not get such a message. I should get
the videoselect page, like in NN.

Platform:
2000-05-29-20 on Linux.

2000-05-19-13 also exhibits the problem, as does M14.
(Reporter)

Comment 1

18 years ago
Adding 4xp keyword.
Keywords: 4xp

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 2

18 years ago
When it loads the CSS stylesheet, it uses Javascript:
if (browser == 'ns4') { . . .

Therefore if you use Mozilla, it doesn't load the stylesheet.
CNN needs to fix their site for forward browser compatibility.

Comment 3

18 years ago
yep
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
Reopened and reassigned to ekrock to evangelize CNN.
Status: VERIFIED → REOPENED
Keywords: top100
Resolution: INVALID → ---

Comment 5

18 years ago
Eric, we need your help to explain CNN/video everything about browser sniffing.
Assignee: pierre → ekrock
Status: REOPENED → NEW
Status: NEW → ASSIGNED
Accepting, M18.
Target Milestone: --- → M18

Comment 7

18 years ago
evangelize component
Component: Style System → Evangelism

Updated

17 years ago
Target Milestone: M18 → ---

Comment 8

17 years ago
--> bclary in Evangelism for as-time-allows investigation & evangelism.
Assignee: ekrock → bclary
Status: ASSIGNED → NEW

Comment 9

17 years ago
Bob Clary said this in an e-mail to me: 

"This evangelism bug was originally about the page not displaying at all, but it
displays fine now and I will be marking it fixed soon.

But when I actually try to view a video from the page RealPlayer does not
display the video but QuickTime does. I am not sure what to make of this. I
think I should file another bug on RealPlayer but don't know how to analyse the
problem. Can you help me triage this?"

I've noticed Real Player's reluctance to play as well.  Can someone shed some
light on what's going on?  Perhaps this ought to be a separate bug.

Comment 10

17 years ago
there's a bug already filed under plugins for 'blank realplayer window on cnn' 
and 'realplayer movie streaming not happening' ( not the exact summaries). maybe 
you are seeing that.
(Assignee)

Comment 11

17 years ago
The realplayer not playing issue is covered in
http://bugzilla.mozilla.org/show_bug.cgi?id=83195.

Since the markup has been fixed I am changing this bug to fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 13

16 years ago
Changing QA contact to component qa
QA Contact: chrisd → zach
problem gone.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.