Deleteing bookmark that contains null character(�) in title causes uncaught exception

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Masahiro YAMADA, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2007122505 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2007122505 Minefield/3.0b3pre

When deleting bookmark that contains null character (x0000; ) in title, error message (uncaught exception) is displayed in Error Console.


Reproducible: Always

Steps to Reproduce:
1.bookmark web page that contains � in title
  example: <title>aaaa&#x0000;bbbb</title>
2.delete bookmark
3.check Error Console.
Actual Results:  
Error message is displayed.
-----------------
-----------------------------------
Error: uncaught exception: [Exception... "'[JavaScript Error: "this.selectedNode.parent is null" {file: "chrome://browser/content/places/menu.xml" line: 467}]' when calling method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://browser/content/places/controller.js :: updatePlacesCommand :: line 1608"  data: yes]
-------------------------

Expected Results:  
If this error causes to bypass to execute some required procedures,
it is needed to fix this error.


I think , if all required procedure is called even if this error is displayed,
this bug can be WONTFIX.
(Reporter)

Comment 1

11 years ago
Created attachment 294549 [details]
testcase
(Reporter)

Comment 2

11 years ago
This bug is reproduced at local file.
I cannot reproduce this with bookmarking attachment 294549 [details].
(Reporter)

Comment 3

11 years ago
This issue may be caused by broken profile.
If I can reproduce with new profile , I ll reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.