Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Resize the whole web page, not just the text

RESOLVED DUPLICATE of bug 4821

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 4821
10 years ago
10 years ago

People

(Reporter: Chris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10

Resizing the text ruins the appearance of many web pages, and some changes to Firefox could rectify this better and more easily than could changes to the web pages' code.

Reproducible: Always

Steps to Reproduce:
1. Visit eg. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/178653
2. Press Ctrl-Plus repeatedly
Actual Results:  
Text and some layout elements become larger, but images stay the same size and become too small. Some text (such as Subscribers >) becomes unreadable.

Expected Results:  
The widths, lengths and thicknesses of all web-page elements -- regardless of the units in which they were specified -- scale up by the same factor, except those that explicitly depend on the window's dimensions. Bicubic resampling is used, unless the user disables it in Preferences, the page's code explicitly specifies nearest-neighbour, or the display has less than 15-bit colour, to ensure that enlarged bitmap images have no aliasing.

Just because this bug is present in all current browsers does not mean that it is not serious. It hurts accessibility, not only for users with limited vision but also for those with any but the largest of high-resolution monitors. Too many web developers assume that their site will be viewed at a specific resolution with sufficiently large pixels at that resolution; others (including those at Google and Wikipedia) keep their bitmap images at a fixed pixel size because current browsers only provide ugly, primitive nearest-neighbour scaling.

Monitors come in many different sizes and resolutions; so should web pages.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 4821
You need to log in before you can comment on or make changes to this bug.