Error message when no components are defined for a product.

VERIFIED FIXED in Bugzilla 2.12

Status

()

P3
minor
VERIFIED FIXED
19 years ago
6 years ago

People

(Reporter: dcassell, Assigned: tara)

Tracking

unspecified
Bugzilla 2.12
Other
Solaris

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
If you create a new product, but do not create any associated components, you 
get this error when you attempt to open a new bug for that product:

>Software error:
>
>Can't use string ("") as an ARRAY ref while "strict refs" in use at
>/usr/data1/webapps/apache/htdocs/bugzilla/enter_bug.cgi line
>240.

Instead of this, it would be helpful to get a nice page explaining that at 
least one component must be associated with a product before a bug can be 
opened for that product. This will spare a good deal of confusion for new 
Bugzilla administrators and users.

Regards.

Damon Cassell
Engage Technologies
(Reporter)

Comment 1

19 years ago
Tara said in email she would check a patch into CVS shortly.  Any word on this?
(Reporter)

Updated

19 years ago
Severity: normal → minor
(Assignee)

Comment 2

19 years ago
Created attachment 9717 [details] [diff] [review]
Patch to handle error condition

Comment 3

19 years ago
This patch doesn't work.  It won't allow any bugs entered.  The problem is with 
the line

! if (0 == $::components{product}) {

that should be

! if (0 == $::components{$product}) {

Sorry.  I'm new enough that this that I'm not comfortable creating diffs yet.  
But after the above fix the patch seems to work.

Comment 4

19 years ago
That wasn't very descriptive ("seems to work").  After applying the patch and 
correcting the omitted $, I was able to enter bugs in my existing product.  
Then I created a product but didn't put and components in it.  When I tried to 
add a bug for that product I received the "need to have at least one component" 
message.

I don't know of any other testing that should be done.  But those two tests 
worked...  :)
(Assignee)

Comment 5

19 years ago
Feh.  Should stop pretending to be a techie and stick to my pod-headed
management job.  Anyway, "fixed".
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Verified on my local machine.
Status: RESOLVED → VERIFIED
*** Bug 31448 has been marked as a duplicate of this bug. ***
*** Bug 51842 has been marked as a duplicate of this bug. ***
*** Bug 39060 has been marked as a duplicate of this bug. ***
*** Bug 69303 has been marked as a duplicate of this bug. ***
In search of accurate queries....  (sorry for the spam)
Target Milestone: --- → Bugzilla 2.12
*** Bug 76305 has been marked as a duplicate of this bug. ***
*** Bug 78675 has been marked as a duplicate of this bug. ***
Moving closed bugs to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified

Comment 15

15 years ago
*** Bug 120907 has been marked as a duplicate of this bug. ***
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.