Back & Forward arrows in Places Organizer do not navigate correctly

VERIFIED DUPLICATE of bug 408860

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 408860
10 years ago
8 years ago

People

(Reporter: abillings, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
In the Places Organizer, the Back and Forward arrows do not navigate correctly between folders.

This was noticed in Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US;
rv:1.9b3pre) Gecko/2007122704 Minefield/3.0b3pre.

If a user navigates to a subfolder within a folder under Bookmarks Menu, selection focus will go back and forth between the subfolder and the folder as as the back button is clicked. The forward button, even after the back button is selected, never becomes active.

Steps to Reproduce

1. Have a folder set up to similar

-- Bookmarks Menu
 -- Firefox
 -- Stuff
 -- Other

for bookmarks.

2. Open the Places Organizer

3. Select the "Firefox" folder, then the "Stuff" folder, and then the "Other" folder, each in turn.

4. Click Back button once.

Note: Selection focus goes from "Other" to "Stuff" and the Forward button is not available (though it should be).

5. Click the Back button again.

Expected Result: Selection focus should go to "Firefox" folder.

Actual Result: Selection focus returns to "Other" folder.

Each time the Back button is pressed, selection focus will switch between the "Firefox" and "Other" folders. The Forward button never becomes available.

Nothing shows up in the Error Console either.
I've noticed that you can only go back/forward between any two folders. If you select different folders in the bookmarks menu tree in the left pane, shouldn't you be able to use 'back' to traverse through all the folders clicked, similar to navigating back through links clicked on a web-page until you reach the 'starting' point of where you first clicked ? 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2007122714 Minefield/3.0b3pre Firefox/3.0 ID:2007122714
Vista HP


(Reporter)

Comment 2

10 years ago
Jim, that's my expectation as well. I also expect that the Forward button is supposed to do something.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408860

Updated

10 years ago
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.