End key does not work on lines with a single character

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
11 years ago
10 years ago

People

(Reporter: jeberger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.6) Gecko/20070208 Mandriva/2.0.0.6-4mdv2007.1 (2007.1) Firefox/2.0.0.6
Build Identifier: Thunderbird 2.0.0.4 (20070620)

The <End> key does not work on lines that contain only one character.


Reproducible: Always

Steps to Reproduce:
1. Open a new message compositing window or reply to an existing message;
2. Type a single character on a line. You may type a carriage return after this character or not, the problem is the same;
3. Put the editing cursor on this line (either before or after the character you typed);
4. Hit the <End> key.
Actual Results:  
The cursor is now before the character (at the beginning of the line) whatever its starting position.

Expected Results:  
The cursor should go to the end of the line.

If you add more characters to the line, the <End> key works properly. If you remove all the characters except one, the bug re-appears.

Comment 1

11 years ago
WFM on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2007122804 Thunderbird/3.0a1pre ID:2007122804

I think the fix may have been bug 336408.

Comment 2

10 years ago
Works for me as well (Windows and Linux).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

10 years ago
Confirmed: I can't reproduce it anymore with v2.0.0.16
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.