Address bar auto-complete forces history selection, instead of new url (only on 1st choice)

VERIFIED DUPLICATE of bug 406487

Status

()

Firefox
Address Bar
VERIFIED DUPLICATE of bug 406487
10 years ago
10 years ago

People

(Reporter: FirasE, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

If you start typing in the address bar a url that matches one in your history, the choices from the history appear. Now if you highlight the first one of those, but then start backspacing (from the end of the address) the highlight still remains and hitting enter forces you to the already visited site instead of the new one typed it. Hard to explain, but the repro steps should make sense.

Reproducible: Always

Steps to Reproduce:
1. Clear your history and go to http://news.yahoo.com/s/afp/20071228/ts_afp/pakistanattacksbhuttoministry
2. Now go to http://news.yahoo.com/s/nm/20071224/pl_nm/usa_politics_clinton_dc
3. Clear the address bar, and type in the address bar 'news.yahoo'
4. Highlight the first url that's suggested (by hitting the down arrow on keyboard)
5. Move the caret to the end of the url (using the keyboard, not mouse) and start backspacing until you only have 'http://news.yahoo.com'
6. Notice the first suggested option remained highlighted and hitting enter forces you to the visited site instead of just news.yahoo.com
7. Repeat steps 1-3, and for step 4 choose the 2nd url that's suggested, then steps 5-6. The newly typed url (news.yahoo.com) is allowed to be used and you're not forced to go with a suggested choice.
Actual Results:  
The suggested url remained highlighted and you are forced to visit that instead of what you typed in.

Expected Results:  
Should have taken you to news.yahoo.com.

Only occurs when you highlight the first suggested choice. Does not "force you" when you highlight second and on.
Is this bug 406179?
(Reporter)

Comment 2

10 years ago
No, I just read 406179 and it describes a different issue.
I can't reproduce this with the latest trunk build on Windows XP. Sounds like a duplicate of bug 400671 or bug 406487.
To test if the issue is really fixed you can use one of these builds:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Comment 4

10 years ago
can't repro on latest nightly. marked as fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 406487
Verified dup; thanks Kevin.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.