When I start a video stream (Flash plug in or media player plug in) the video after a few seconds freezes.

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: Sharon, Unassigned)

Tracking

1.9.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-09-15], URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

When I start a video stream (Flash plug in or media player plug in) the video after a few seconds freezes. If I move the progress bar the video resumes for a few seconds and freezes again.

Reproducible: Always

Steps to Reproduce:
1.Run any movie on Youtube
2.
3.


Expected Results:  
The video just freezes.

Play the stream normally without ant freezing.

Updated

11 years ago
Component: Extension Compatibility → Plug-ins
Product: Firefox → Core
QA Contact: extension.compatibility → plugins

Comment 1

11 years ago
I just wanted to add my comment here. I have the same issue only with Firefox (2.0.0.12). Happening on a desktop and laptop both recently wiped completely, re-partitioned and formatted. Clean installs of Windows XP Prof. and XP Media. Installed Flash, Shockwave, Java (from sun micro) only. No other plug-ins at the time of testing. Check all settings to turn off pop up blocking and made sure all setting enabled for Java etc... No firewall or anti-virus installed at the time of testing/problem. Video plays for 2 seconds and stops (like paused). Video continues to buffer until complete. Tried clicking Pause or stop and then play after buffer was complete, still no good. Just wanted to add this cause I had clean installed everything with no other plug-ins or anti-virus, ad-blockers or anything else other then the OS, Firefox and above mentioned plug-ins/add-ons.

Comment 2

11 years ago
I'd like to third this issue; no Flash assets will play when there are multiple tabs open in 2.0.0.12. (XP Pro, no plug-ins, no pop-up blocking, no firewall or antivirus interfering.) Problem is almost always solved by restarting Firefox. 
In the latest Firefox nightly, any flash video freezes after just a second or two, no matter what I do ( restart Firefox, computer, etc. ).

Comment 4

10 years ago
I have the same problem! Both in 2.x versions and in 3RC1 (and in the beta versions, too), if i open multiple tabs (5-10) videos won't play (just for ~2secs, and without sound.
Solution is to close firefox (not just one window, all of them, so the whole program), and restart it, and open just a few tabs, and watch the video :D

I hope there will be a solution soon, because it's very annoying (i use lots of tabs all the time...)

Comment 5

10 years ago
Same here and this is REALLY starting to bug me.

Comment 6

10 years ago
I installed the new 3.0 and the problem seems to have gone away for now. I suggest everyone download 3.0 from firefox.com right away and give it a try... 

Comment 7

10 years ago
I also have had this problem. It doesn't happen all the time, though. It will work fine for a while, then all of sudden the problem starts - no audio and video freezes after a few seconds. I can click the progress bar to get it going again with no audio, but after a few seconds it quits again. I can do this repeatedly. Also, it will do it for all videos across all sites I try. Perhaps it's a plug-in issue. Anyhow, I can fix it by killing the firefox task - all Firefox windows close and I restart, restoring the previous tabs. All videos work fine again for awhile - perhaps along while, perhaps not.

I will eventually download and install 3.x, but don't have time right now... :-)

Comment 8

10 years ago
Version 3.0 does fix this bug and quite well, thank you.

Good to see this one go away.

Comment 9

10 years ago
I installed 3.0 - no change. Works for a while then hangs up just like under 2.15.

Comment 10

10 years ago
Same here, 3.0 does not solve the issue....I hope they will fix this soon

Comment 11

10 years ago
I would like to add my report here too. I've had this issue on and off for months now, I've also reported it before, to no avail. I am currently running Firefox 3.0, it ran fine for a while, but just began happening again. When running videos it will load the entire video, but only play the first 2-3 seconds, and I've also noticed there is no sound when runing. If you skip on in the video, it'll play another 2-3 seconds, again no sound, and freeze again. This has *NOT* been fixed in 3.0, and honestly I doubt it's fixed in any build of Minefield. The only problem is I know for a fact if I install Minefield it'll work, until a week or two later it'll start happening again. I can assure you, in my situation anyway, A clean install will more than likely fix this. However it will begin happening again out of the blue - I was watching a video I have watched tens of times before when this started happening again. Hope someone will pick this one up!

Comment 12

10 years ago
I have had this problem on various computers, various Windows versions, and various version of Firefox, include 3.0.  It happens with all videos, including CNN.com videos.  

Comment 13

10 years ago
I've found this problem with the Flash 9 player in Firefox 3 under Windows Vista Ultimate on 3 brand-new computers from different manufacturers. There are no problems with the Flash 9 player in Internet Explorer on the same machines.

One way to fix it TEMPORARILY is to right-click a Flash video, select Settings, click the Advanced button, then use the online dialog box to delete all stored files. Then you have to close the browser and reboot (or log out and back in). Unfortunately, you'll have to do this "fix" several times a day. Or copy the video's URL and paste it into IE.

Comment 14

10 years ago
I haven't had the problem for quite some time now.  I have Flash 9,0,115,0 and Windows XP, Tablet Edition 2005, Version 2002, SP 3, and Firefox 3.0.3.  Not sure what changed, but I'm happy to be free of the problem.

When I did have the problem, the easiest fix for it was the start the Windows Task Manager (Ctrl-Alt-Del), click the Processes tab, find "firefox" in the list, highlight it and click End Process.  When told that data could be lost or other undesired results, I clicked OK.  Then I restarted Firefox and restored the to the previous session.  This would fix it every time for me.

Comment 15

10 years ago
THERE IS NOW A FIX! Upgrade to the Flash 10 player, and videos will play normally, once again. There is a good writeup on the problem (and fix) at http://www.readwriteweb.com/archives/flash_10_released_finally_flash_works_in_firefox_again.php.

Comment 16

8 years ago
Do you still see this problem using the most recent versions of all components (application, plugins and add-ons)?

If you do not, please close the bug with resolution set to WORKSFORME. If problem was caused by add-on or non-mozilla code please use INVALID resolution.
If you do still see the problem, please comment in the bug.
Whiteboard: [closeme 2010-09-15]
Closing since now after whiteboard closeme date and no reply to last comment.

Please reopen/comment with further info, if you still see this issue with Firefox 3.6.13 or later, with a clean profile and the latest version of the plugin.

If you wish, you can also try to reproduce in Firefox 4 Beta 8 or later:
http://www.mozilla.com/en-US/firefox/all-beta.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 1.9.0 Branch
You need to log in before you can comment on or make changes to this bug.