Search by add-on GUID

RESOLVED FIXED in 4.x (triaged)

Status

addons.mozilla.org Graveyard
Public Pages
P4
enhancement
RESOLVED FIXED
10 years ago
2 years ago

People

(Reporter: fligtar, Assigned: davedash)

Tracking

4.x (triaged)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
If someone searches for a valid add-on GUID string, we should search addons.guid to try to find that add-on.

There's no way for someone to look up what add-on is associated with a GUID right now, and it's something that is done often enough to warrant this, I think.

Updated

10 years ago
Severity: normal → minor
Target Milestone: --- → 3.x (triaged)
CCing davedash - easy to add?  This should be done on the admin panel too.
Severity: minor → enhancement
Priority: -- → P4
Easy to add.  

If you want to limit to just the guid field the format will be:

guid:MYAWESOMEGUID.
(In reply to comment #2)
> Easy to add.  

I begin to like Sphinx.
Created attachment 410683 [details] [diff] [review]
v1

This patch:
* allows limited JSON output in the Search API
* queries in FE and API by guid
* queries like this:
http://addons.mozilla.dev/en-US/firefox/api/1.2/search/guid:%7B78518e5b-4eb1-0d61-ff3e-fd645642a4e2%7D,canuckstoolbar@canucks.nhl.com/?format=json

The query format is

guid:GUID1,GUID2,GUID3

-d
Assignee: nobody → dd
Status: NEW → ASSIGNED
Attachment #410683 - Flags: review?(clouserw)
Comment on attachment 410683 [details] [diff] [review]
v1

cool
Attachment #410683 - Flags: review?(clouserw) → review+
I <3 U!
------------------------------------------------------------------------
r55264 | ddash@mozilla.com | 2009-11-05 18:57:00 -0800 (Thu, 05 Nov 2009) | 2 li

[bug 410277] JSON support for search/guids

------------------------------------------------------------------------
r55263 | ddash@mozilla.com | 2009-11-05 18:56:55 -0800 (Thu, 05 Nov 2009) | 2 li

[bug 410277] storing guids in index
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
post-Fixed dependency so this can work in Preview.
Depends on: 527138
Created attachment 411319 [details] [diff] [review]
v2

v1 works on 64bit systems, but PHP is 32bit signed, and CRC32 gives us 32-bit unsigned integers.

So I have to send these to sphinx as strings.
Attachment #410683 - Attachment is obsolete: true
Attachment #411319 - Flags: review?(clouserw)
Attachment #411319 - Flags: review?(clouserw) → review+
Comment on attachment 411319 [details] [diff] [review]
v2

if you say so
I do say so :)


------------------------------------------------------------------------
r55765 | ddash@mozilla.com | 2009-11-09 16:59:14 -0800 (Mon, 09 Nov 2009) | 2 li

[bug 410277] CRC32 doesnt work well as an int because PHP is stupid and doesnt h
Duplicate of this bug: 526628
Sample query:

https://preview.addons.mozilla.org/en-US/firefox/api/search/guid:canuckstoolbar@canucks.nhl.com,%7B78518e5b-4eb1-0d61-ff3e-fd645642a4e2%7D?format=json
Duplicate of this bug: 530398
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.