Currently viewed application should not appear in "Other Applications" dropdown

VERIFIED FIXED

Status

VERIFIED FIXED
11 years ago
3 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
Summary: "Other Applications" dropdown should probably not include Firefox when chosen app/view is Firefox

Steps to Reproduce:

1. Log on to https://remora-reskin.stage.mozilla.com/en-US/firefox/
2. Click the "Other Applications" dropdown

Actual Results:

When in the /firefox view, it shows:
SeaMonkey
Sunbird
Thunderbird
Firefox

If "Firefox" should appear (note that it doesn't on http://mozilla.focalcurve.com) when in the Firefox view, then it should at least have its icon in the dropdown; as it stands, we probably should remove "Firefox" from the choice when it's the currently viewed app.

Madhava: what say you?
That's right -- the currently featured application should not be in the dropdown.
(Reporter)

Comment 2

11 years ago
Adjusting summary from "'Other Applications' dropdown should probably not include Firefox when chosen app/view is Firefox" to "Currently viewed application should not appear in "Other Applications" dropdown", since this affects Sunbird, Thunderbird, and SeaMonkey, too.
Summary: "Other Applications" dropdown should probably not include Firefox when chosen app/view is Firefox → Currently viewed application should not appear in "Other Applications" dropdown

Comment 3

11 years ago
What order do they have, anyway? In terms of likelyhood what people could be looking for when clicking that button, I'd suggest the order Fx, Tb, Sm, Sb. The new one seems slightly random to me, or am I missing something?
(Reporter)

Comment 4

11 years ago
They're currently in alphabetical order, which matches the spec's mockups at http://people.mozilla.com/~madhava/files/amo/2007-11-21/; I'm not suggesting that they stay in that order, though.

Comment 5

11 years ago
Ah, okay; yeah I don't think that's the best order (and why is Fx at the bottom then? weird). Do we need a new bug for that?
(Reporter)

Comment 6

11 years ago
(In reply to comment #5)
> Ah, okay; yeah I don't think that's the best order (and why is Fx at the bottom
> then? weird). Do we need a new bug for that?

That's what this whole bug is about; see comment 1 and comment 2 :-)

Updated

11 years ago
Blocks: 411642

Comment 7

11 years ago
Actually no, it's not about the weird app picker order that you get in all applications' pages. I filed bug 411642. Should be an easy fix :)
(Reporter)

Comment 8

11 years ago
(In reply to comment #7)
> Actually no, it's not about the weird app picker order that you get in all
> applications' pages. I filed bug 411642. Should be an easy fix :)

Sorry, I was responding to, "(and why is Fx at the bottom
then? weird). Do we need a new bug for that?"

Comment 9

11 years ago
(In reply to comment #8)
> Sorry, I was responding to, "(and why is Fx at the bottom
> then? weird). Do we need a new bug for that?"

Ah, sorry for the misunderstanding. I meant it is out of order, even alphabetically.
I fixed this in the 3.2 redesign branch, SVN r9794.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

11 years ago
Verified FIXED using IE 6/7, Safari 3.04, Firefox 2.0.0.11 and Opera 9.25 (Windows, with Mac testing in Safari and Firefox).
Status: RESOLVED → VERIFIED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.