Sometimes, the "Go to Download Page" context menu item is disabled, where it shouldn't

RESOLVED INVALID

Status

()

Toolkit
Downloads API
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: Nikos Platis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; el; rv:1.9b3pre) Gecko/2007123005 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; el; rv:1.9b3pre) Gecko/2007123005 Minefield/3.0b3pre

The Download Manager seems to be work in progress, but here is one bug that I noticed: Sometimes, the "Go to Download Page" context menu item is disabled for downloads initiated via "Save link as..."

Reproducible: Always

Steps to Reproduce:
1. Go to ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk-l10n/
2. Click on a link to download a file.
3. Right-click on a (different) link to download another file
Actual Results:  
Switch to the Download Manager and right-click on each of the entries. Observe that the "Go to Download Page" is disabled for the file downloaded via "Save as..." but it is enabled for the other file.

Expected Results:  
The menu items should be enabled in both cases. The user would not see any difference

The problem does not appear when using http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk-l10n/ (the difference is in the protocol).
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; el; rv:1.9b3pre)
> Gecko/2007123005 Minefield/3.0b3pre
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; el; rv:1.9b3pre)
> Gecko/2007123005 Minefield/3.0b3pre
> 
> The Download Manager seems to be work in progress, but here is one bug that I
> noticed: Sometimes, the "Go to Download Page" context menu item is disabled for
> downloads initiated via "Save link as..."
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Go to ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk-l10n/
> 2. Click on a link to download a file.
> 3. Right-click on a (different) link to download another file
> Actual Results:  
> Switch to the Download Manager and right-click on each of the entries. Observe
> that the "Go to Download Page" is disabled for the file downloaded via "Save
> as..." but it is enabled for the other file.
> 
> Expected Results:  
> The menu items should be enabled in both cases. The user would not see any
> difference
> 
> The problem does not appear when using
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk-l10n/ (the
> difference is in the protocol).

-> Invalid; this is by design, as it means we don't have a referrer.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.