yahoo.com - 2008 builds no longer work

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
--
blocker
VERIFIED FIXED
11 years ago
3 years ago

People

(Reporter: Samuel Sidler (old account; do not CC), Assigned: kev)

Tracking

({top100})

Details

(URL)

yahoo.com no longer loads builds that have 2008 in their user agent strings.

This build works fine: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2007123105 Minefield/3.0b3pre 

This build fails: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3pre) Gecko/2008010104 Minefield/3.0b3pre

This happens in Minefield and other browsers on all platforms. Stephen confirmed that changing his UA to a working build's UA fixed the issue.
Add "Gecko/20071231" to the pref "user.agent.extra.[product]" and reload the site.

They're blocking Gecko versions older than October 2004 and newer than December 2007...
OS: Mac OS X → All
Hardware: PC → All
general.useragent.override with value of "Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2007123105 Minefield/3.0b3pre" was what I did to get it working.

Comment 3

11 years ago
*sigh*

This isn't the first time this has happened over there. I can't find the link/bug right now, but Yahoo apparently decided the world was going to end on 31 October 2007 as well.

Comment 4

11 years ago
My apologies. I was remembering VersionTracker, not Yahoo: bug 402337.

But yeah, this sort of thing crops up every so often. Boo.
(Reporter)

Comment 5

11 years ago
Do we have contacts at Yahoo we can alert about this bug and bug 410394?

This bug, more so than bug 410394, will affect the next release of Firefox 2.0.0.x as it will have a build ID in 2008.

Bug 410394 will matter for Firefox 3 and beyond (as far as Firefox is concerned). Hopefully they'll fix it by then but it might be good to contact them now.
(Assignee)

Comment 6

11 years ago
Have raised this with my contacts at Yahoo!, and will escalate if I don't have anything by Friday.

Updated

10 years ago
Assignee: english-us → kev
(Assignee)

Comment 7

10 years ago
Exchanged email with Yahoo! Corp, and this has been identified and corrected. Fix should be pushed within 24 hours to the Y! properties.
(Reporter)

Comment 8

10 years ago
This fix is now live. Thanks Kev!
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Tested on all of today's trunk builds, on Mac OS X 10.4, Windows Vista, and Ubuntu 7.04; verified.
Status: RESOLVED → VERIFIED

Comment 10

10 years ago
http://hk.yahoo.com/ still has the same issue.. perhaps other localized Yahoo properties as well.
Reopening. With the following user agent string I'm not allowed in by www.yahoo.com ("Why miss out? To see all the new Yahoo! home page has to offer, please upgrade to a more recent browser." - do they mean the next nightly or what? :)).

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; pl; rv:1.9.1b3pre) Gecko/20090107 Shiretoko/3.1b3pre

With the user agent string from comment 2 they let me in.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(In reply to comment #11)
That is bug 471816.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → FIXED
Verified, since what we're seeing now is bug 471816.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.