Fix Fx to pass required parms to Thunderbird to subscribe RSS

RESOLVED INVALID

Status

()

Firefox
RSS Discovery and Preview
RESOLVED INVALID
11 years ago
6 years ago

People

(Reporter: alta88, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11 XPCOMViewer/0.9.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11 XPCOMViewer/0.9.5


ref bug 394491#c8.

Reproducible: Always
(Reporter)

Comment 1

11 years ago
Created attachment 295104 [details]
FeedConverter.js fix for Tb subscribing
Attachment #295104 - Flags: review?(philringnalda)
Attachment #295104 - Flags: approval1.9?
(Reporter)

Comment 2

11 years ago
Created attachment 295105 [details] [diff] [review]
FeedConverter.js patch for Tb rss
Attachment #295104 - Attachment is obsolete: true
Attachment #295105 - Flags: review?(philringnalda)
Attachment #295105 - Flags: approval1.9?
Attachment #295104 - Flags: review?(philringnalda)
Attachment #295104 - Flags: approval1.9?
Comment on attachment 295105 [details] [diff] [review]
FeedConverter.js patch for Tb rss

While that's an automatic r- for only covering "thunderbird.exe" and not also "Thunderbird.app" and "thunderbird-bin", I would expect that a Firefox member/peer/owner (who is actually able to review or decide, unlike me) would say that the whole bug is WONTFIX - back before Fx started sending feed: URLs on all platforms, Thunderbird had a little excuse for not being willing to treat bare http: URLs on the commandline as feeds, but it has no excuse for not treating bare feed: URLs as feeds.
Attachment #295105 - Flags: review?(philringnalda)
Attachment #295105 - Flags: review-
Attachment #295105 - Flags: approval1.9?
(Reporter)

Comment 4

11 years ago
well expanding the test with a regex eg is an easy thing to do..

1. no one can argue Tb rss and the whole project is not problematic.
2. Fx should respect arguments required by other apps; the longstanding bug to support args in helper app handling is still longstanding - and that's a Fx flaw.
3. it's not a valid argument at all that Fx mandates what args other apps use, imo.  there is no accepted spec on feeds, just pre-specs and proposals. can you point to an rfc that states requiring -mail feed: is wrong?
4. most importantly, there's no reason users should suffer when a few lines of code fixes this.  there is no current checked in fix in Tb trunk; even if there were it's a question of "if" not "when" we ever see a new Tb..  leaving it broken and resorting to fingerpointing is not the way to go on this.

i was interested in your comments anyway given your fingerprints in rss-land.  if you're not the final word, who is?
See http://www.mozilla.org/projects/firefox/review.html for appropriate reviewers - in this case probably Mano, Gavin, or Sayre.
(Reporter)

Comment 6

11 years ago
Comment on attachment 295105 [details] [diff] [review]
FeedConverter.js patch for Tb rss


if subscribing rss to outlook was a fx3 blocker, i'm hoping we can extend the same courtesy to Tb.
Attachment #295105 - Flags: review?(mconnor)
Attachment #295105 - Flags: review-
Attachment #295105 - Flags: approval1.9?

Comment 7

11 years ago
Comment on attachment 295105 [details] [diff] [review]
FeedConverter.js patch for Tb rss

Please re-request approval once reviews are done..
Attachment #295105 - Flags: approval1.9?
Version: unspecified → Trunk
Comment on attachment 295105 [details] [diff] [review]
FeedConverter.js patch for Tb rss

clearing this request since I'm not reviewing it, but per-app hacks are bad.  We should just be able to pass this using OS standard protocol handler bits.  If we can't, thunderbird needs to fix their stuff.
Attachment #295105 - Flags: review?(mconnor)

Comment 9

10 years ago
Yeah, this is pretty icky.  Alta88/myk/nth10sd do you guys know if there's a Thunderbird bug filed on this on already?  If so, I'd probably be willing to mark it blocking-thunderbird3...
bug 348450, which you did +, four months ago, plus bug 304704 which will require you to find someone capable of making sense of toolkit's Mac commandline handling so they can deal with its failure to run commandline handlers when the app is running.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
(Reporter)

Comment 11

6 years ago
this is no longer valid.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.