crash when using copy/paste in X

VERIFIED WORKSFORME

Status

SeaMonkey
General
P3
critical
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: zzed, Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: worksforme? (05-30))

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; I; Linux 2.0.38 i586)
BuildID:    2000052908

If I select something in the URL-field with the mouse and then try
to select and paste something in another window in X (a xterm, for
example) Mozilla segfaults.

Reproducible: Always
Steps to Reproduce:
Method A:
1. Start Mozilla.
2. Make a selection in the URL-field with the mouse.
3. Remove the selection by clicking once.
4. Start a xterm.
5. In the xterm, select some text and paste it (in the xterm) with
   the middle button.
6. Voila!

Method B:
1. Start Mozilla.
2. Make a selection in the URL-field with the mouse.
3. Start a xterm.
4. Make a selection in the xterm with the mouse.
5. Voila!


Debain 2.1/2.2 (XFree86 3.3.2.3a, glibc 2.1.3)
I can't reproduce this in my build from the 30th (and I think I would have
noticed it in yesterday's build too).  Do you have a stack trace?
Whiteboard: worksforme? (05-30)
(Reporter)

Comment 2

18 years ago
works now both with nightly 2000052908 and my own CVS build.

it was my strange, special mixed Debian 2.1/2.2 library setup that didn't work

so well apparently. i run mozilla in a pure 2.2 environment now.

Comment 3

18 years ago
worksforme on 200060409
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 4

18 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr

Comment 5

18 years ago
Adding crash keyword
Keywords: crash

Comment 6

18 years ago
verified, Linux cvs build 071700
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.