deleting an item in history sometimes selects item on top of the list

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
P2
normal
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Daniel.S, Assigned: mano)

Tracking

({regression})

Trunk
Firefox 3
regression
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WFM?])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
In the History section of the Library, when I delete an item which is not the first on the list, sometimes not only the item followed by the deleted item is selected but the first item on the list as well.

STR:
1. Open the Library and go to History.
2. Select any but the topmost item on the list.
3. Press the Delete key a few times.

After some deletions the history-item on the top is randomly selected as well. It shouldn't get selected.

To be visual:

(first item)
(fellow item1)
[fellow item2] (selected)
(fellow item3)

Deleting the selected item results in:

[first item] (selected)
(fellow item1)
[fellow item3] (selected)
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008010209 Minefield/3.0b3pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
Regression window is http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1198170600&maxdate=1198178279 -> Bug 393870.
Blocks: 393870
Flags: blocking-firefox3?
Keywords: regression

Comment 3

10 years ago
332047 could help here (should check after it's checked-in)

Comment 4

10 years ago
i can confirm that with patch in bug 332047 i cannot reproduce
We should fix this in PlacesTreeView by comparing the visit id.
Assignee: nobody → mano
Created attachment 296589 [details] [diff] [review]
more selection work

Hopefully we'll get to remove the two other types by time for beta.
Attachment #296589 - Flags: review?(dietrich)
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → Firefox 3 M11
Comment on attachment 296589 [details] [diff] [review]
more selection work

thanks, r=me.
Attachment #296589 - Flags: review?(dietrich) → review+

Updated

10 years ago
Flags: blocking-firefox3? → blocking-firefox3+
mozilla/browser/components/places/content/controller.js 1.193
mozilla/browser/components/places/content/tree.xml 1.89
mozilla/browser/components/places/content/treeView.js 1.28
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008030206 Minefield/3.0b4pre ID:2008030206

This is not fixed. I just noticed this bug is still appears.

Here are STR that should work for everybody:
1. Create a new profile; middle click the Livemark to accumulate some history items.
2. In History-Library, select any item after the topmost one and delete it.

Results: The item on top of the list is unexpectedly selected.

It only happens sometimes, but often from my point of view.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #9)
>
Confirmed, but it only seems to happen with the items without an icon and without tooltip. It behaves how it should with history items with a BBC icon, name and tooltip. I's not clear to me why only the half of the feed's sites has favicons.
Target Milestone: Firefox 3 beta3 → Firefox 3
This seems to WFM now, I can't reproduce on current Mac trunk, even with Ria's steps.
Whiteboard: [WFM?]
(Reporter)

Comment 12

10 years ago
Yeah, I also wasn't able to reproduce this on todays Win Nightly.

However, I noticed that sometimes when the last item in the list is deleted, the selection is lost instead of moving to the item that's the last one now. But it's possible that this is reported elsewhere.
Pretty sure it is, resolving WFM.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.