[Mac] Firefox should know when the system no longer has an internet connection and work offline

RESOLVED WORKSFORME

Status

()

Firefox
Shell Integration
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: sdwilsh, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Basically, if the user disables their internet connection or loses it, we should automagically work offline.  Colin indicated that it is in fact doable.
Flags: blocking-firefox3?
Firefox 3 on Linux already does this.
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Firefox 3 on Linux already does this.
Please note the OS that this was filed for...
(In reply to comment #2)
> (In reply to comment #1)
> > Firefox 3 on Linux already does this.
> Please note the OS that this was filed for...

I did notice and note it. I was just noting that fact for others.
Component: General → OS Integration
QA Contact: general → os.integration
Summary: Firefox should know when the system no longer has an internet connection and work offline → [Mac] Firefox should know when the system no longer has an internet connection and work offline
This does not block the final release of Firefox 3.
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-

Comment 5

10 years ago
Remove [Mac] tag, switch Platform from PC -> Mac which shows "Mac" in the search results and thus does the same thing
Hardware: PC → Macintosh
Summary: [Mac] Firefox should know when the system no longer has an internet connection and work offline → Firefox should know when the system no longer has an internet connection and work offline

Comment 6

10 years ago
Whoops, noticed reed did it, putting it back.
Summary: Firefox should know when the system no longer has an internet connection and work offline → [Mac] Firefox should know when the system no longer has an internet connection and work offline
I just tested latest trunk build (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b2pre) Gecko/20081113 Minefield/3.1b2pre ID:20081113020254) on OS X 10.4. 

On that system this bug is invalid, Firefox switches to offline mode when I a) turn of air port b) turn of access point c) unplug the cable. Probably, as Reed Loden mentioned in comment 1, the linux fix works also on the BSD code of OS X or this bug is duplicate of some other I am not aware of.

If anyone wanted to detect there is not an internet connection even a local network connection is fine then it IMHO is impossible or pretty difficult task.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 8

8 years ago
WFM, since don't know what fixed this.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.