When savings as PDF, just ".pdf" suggested as file name

RESOLVED DUPLICATE of bug 312018

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 312018
10 years ago
9 years ago

People

(Reporter: Brian L. Matthews, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2

When saving a page as PDF through the print dialog, the suggested file name is just ".pdf". In released versions of Firefox, it's something like "<window title>.pdf"

Reproducible: Always

Steps to Reproduce:
1. Choose File:Print...
2. Choose PDF:Save as PDF...
Actual Results:  
The suggested file name in the save dialog is just .pdf.

Expected Results:  
The suggested file name should be something like <window title>.pdf (whatever it is in Firefox 2.x).
Confirming, I see this on 10.5 and I believe I have seen it on 10.4 as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

10 years ago
This should be retested in tomorrow's trunk build, as the checkin for bug 312018 likely fixed this.
Duplicate of this bug: 411876
Is this a dupe of bug 303547?
Probably, but feel free to take your pick ;)  It was never clear to me what circumstances caused which name, as I would see them interchangeably sometimes.
(Reporter)

Comment 6

9 years ago
This has been working fine since at least the final 3.0, so this bug could be closed (or marked as a dup of bug 303547).
Duping to bug 312018 (since that's where the patch was), per comment 6.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 312018
You need to log in before you can comment on or make changes to this bug.