unicode command line args truncated

RESOLVED DUPLICATE of bug 410610

Status

()

Toolkit
Startup and Profile System
RESOLVED DUPLICATE of bug 410610
10 years ago
10 years ago

People

(Reporter: Cal Henderson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Nightly 2008-01-02

When launching a xul-runner app with a unicode filename as a commandline parameter, the parameters get truncated in various ways. this only happens for the first instantiation, not for subsequent remoting executions (those all work fine).

some test filenames and what gets passed to a commandline handler:

'foo.txt' -> 'foo.txt'
'你好.txt' -> '你好' (missing file extension)
'你好-foo.txt' -> '你好-foo' (missing file extension)
'你好-你好.txt' -> '' (blank string)

in the last instance, i still get an arg (cmdLine.length in my handler is 1), but cmdLine.getArgument() returns a blank string.

Reproducible: Always
(Reporter)

Comment 1

10 years ago
confirmed still broken on trunk as of noon 2008-01-02

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 410610
(Reporter)

Comment 3

10 years ago
confirmed fixed on trunk

Updated

10 years ago
Component: XRE Startup → Startup and Profile System
QA Contact: xre.startup → startup
You need to log in before you can comment on or make changes to this bug.