Titles disappeared in Window when I moved a message to the trash -- nsIMsgFolder.getMsgDatabase]" nsresult: "0x80550005 (<unknown>)" ... chrome://messenger/content/mailWidgets.xml

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Dan Pollack, Unassigned)

Tracking

x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 2.0.50727)
Build Identifier: 2.0.0.9 20071031

Error: uncaught exception: [Exception... "Component returned failure code: 0x80550005 [nsIMsgFolder.getMsgDatabase]"  nsresult: "0x80550005 (<unknown>)"  location: "JS frame :: chrome://messenger/content/mailWidgets.xml :: parseFolder :: line 2061"  data: no]

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.



Just moved the file and left the main title window alone?
(Reporter)

Comment 1

10 years ago
Trash icon disapeared until I sent another item to it. Only the Mailbox labeled In is affected, none of the sub-folders are.
Version: unspecified → 2.0

Comment 2

9 years ago
your description is rather incomplete.
* what exact steps lead up to your getting the error message? 
* are you on an exchange server?

removed "related to bug 396169?
Summary: Titles disappeared in Window when I moved a message to the trash - related to 396169? → Titles disappeared in Window when I moved a message to the trash -- nsIMsgFolder.getMsgDatabase]" nsresult: "0x80550005 (<unknown>)" ... chrome://messenger/content/mailWidgets.xml
Reporter can ypu reply to comment #2?
Whiteboard: closeme 2009-08-30
(Reporter)

Comment 4

9 years ago
(In reply to comment #2)
> your description is rather incomplete.
> * what exact steps lead up to your getting the error message? 
> * are you on an exchange server?
> removed "related to bug 396169?

It's been so long...... But I usually delete e-mails in groups. I know these are junk, so I'll delete a group. Then read individual ones that may/may not be junk and delete as needed usually using the Delete button on the window. Sometimes, I will d'n'd to Trash. I don't usually sort e-mails, so I can accumulate quite a large number (for me) in my Inbox, upwards of 600.

No, I am not on an Exchange Server.

Updated

9 years ago
Whiteboard: closeme 2009-08-30

Comment 5

9 years ago
I don't know if this confirms the bug, but generally uncaught exceptions should be fixed so at least they are caught!

Best guess at steps to reproduce:
I started seeing this after loading yesterday morning's a1pre shredder. Since starting up that version (though it could be a coincidence) I have not been able to download any other mail.

Prior to the uncaught exception, there were a number of WARN messages in the Error Console that ended in the operation 'Bailing' (that is the term in the message).

Error: uncaught exception: [Exception... "Component returned failure code: 0x80550006 [nsIMsgFolder.msgDatabase]"  nsresult: "0x80550006 (<unknown>)"  location: "JS frame :: chrome://messenger/content/mailWidgets.xml :: parseFolder :: line 2007"  data: no]

I *am* on an Exchange server using IMAP.

Based on this message, I assume that something may have corrupted the Message Database for this folder and that it needs rebuilding. Before I do this, I am willing to use my owa client for a day or so to collect any other information that might be useful.
Dan\Derek, do you have the same experience issue with latest TB 3.1.x release?
Whiteboard: closeme 2010-07-25
(Reporter)

Comment 7

8 years ago
No loonger showing this problem. It can be closed.
WFM per comment #7 (at least in release 3.x.x)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: closeme 2010-07-25
You need to log in before you can comment on or make changes to this bug.