utf8 "\xC1" does not map to Unicode

RESOLVED INVALID

Status

()

Bugzilla
User Interface
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: linxin12, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; InfoPath.1)
Build Identifier: Stable Release (3.0.2) or Release 3.1.2

Removing existing compiled templates ...
Precompiling templates...
utf8 "\xC1" does not map to Unicode at /usr/lib/perl5/5.8.3/i386-linux-thread-multi/Encode.pm line 164.

Reproducible: Always

Steps to Reproduce:
1.copy the template cn to template directory,and run 
2.run ./checksetup.pl 
3.
Actual Results:  
run ./checksetup.pl 
* Running on Linux 2.6.3-7mdk #1 Wed Mar 17 15:56:42 CET 2004

Checking perl modules...
Checking for             CGI (v2.93)   ok: found v3.31
Checking for        TimeDate (v2.21)   ok: found v2.22
Checking for             DBI (v1.41)   ok: found v1.50
Checking for       PathTools (v0.84)   ok: found v3.05
Checking for Template-Toolkit (v2.12)   ok: found v2.19
Checking for      Email-Send (v2.00)   ok: found v2.192
Checking for Email-MIME-Modifier (any)     ok: found v1.442

Checking available perl DBD modules...
Checking for          DBD-Pg (v1.45)   ok: found v1.49
Checking for       DBD-mysql (v2.9003) ok: found v4.005

The following Perl modules are optional:
Checking for              GD (v1.20)   ok: found v2.32
Checking for     Template-GD (any)     ok: found v1.56
Checking for           Chart (v1.0)    ok: found v2.3
Checking for         GDGraph (any)     ok: found v1.4307
Checking for      GDTextUtil (any)     ok: found v0.86
Checking for        XML-Twig (any)     ok: found v3.32
Checking for      MIME-tools (v5.406)  ok: found v5.418
Checking for     libwww-perl (any)     ok: found v2.024
Checking for     PatchReader (v0.9.4)  ok: found v0.9.5
Checking for      PerlMagick (any)     ok: found v6.3.7
Checking for       perl-ldap (any)     ok: found v0.31
Checking for       SOAP-Lite (any)     ok: found v0.69
Checking for     HTML-Parser (v3.40)   ok: found v3.56
Checking for   HTML-Scrubber (any)     ok: found v0.08
Checking for Email-MIME-Attachment-Stripper (any)     ok: found v1.314
Checking for     Email-Reply (any)     ok: found v1.202
Checking for        mod_perl (v1.999022) ok: found v2.000003
Checking for             CGI (v3.11)   ok: found v3.31
Checking for      Apache-DBI (v0.96)   ok: found v1.06
Reading ./localconfig...
Checking for       DBD-mysql (v2.9003) ok: found v4.005
Checking for           MySQL (v4.1.2)  ok: found v4.1.19-max-log

Removing existing compiled templates ...
Precompiling templates...
utf8 "\xC1" does not map to Unicode at /usr/lib/perl5/5.8.3/i386-linux-thread-multi/Encode.pm line 164.

Expected Results:  
no error!

no
This is not a security bug.

I suspect the Chinese templates you installed don't use UTF8 as the character set.  Bugzilla 3 and up require everything to be UTF8.
Group: webtools-security

Updated

10 years ago
Assignee: database → ui
Severity: critical → major
Component: Database → User Interface
OS: Linux → All
Hardware: PC → All

Comment 2

10 years ago
Is it really a bug in Bugzilla? If templates are not written in UTF8, then that the translator's fault.
Version: unspecified → 3.0.2
(Reporter)

Comment 3

10 years ago
Like Dave Miller (MoCo) said,It is character set problem!thank you!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 4

10 years ago
That makes this INVALID, not FIXED.
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.