Last Comment Bug 410639 - Provide ability to change update channel within the application
: Provide ability to change update channel within the application
Status: RESOLVED DUPLICATE of bug 642765
:
Product: Toolkit
Classification: Components
Component: Application Update (show other bugs)
: Trunk
: All All
: -- enhancement with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
https://wiki.mozilla.org/Application_...
: 567563 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-03 07:52 PST by Robert Strong [:rstrong] (use needinfo to contact me)
Modified: 2011-04-20 15:45 PDT (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Robert Strong [:rstrong] (use needinfo to contact me) 2008-01-03 07:52:55 PST
Spinoff of the opt-in part of bug 405463 comment #0.

There was some discussion of making it so the installer provides this which I am very much against doing. If such functionality is desired IMO it should be part of the application.
Comment 1 Jesse Ruderman 2009-07-16 06:52:01 PDT
We could add a checkbox, "Update to beta versions when available", in Options > Advanced > Update.  (This is the wording Adium uses.)

Or we could offer beta versions to users who check for updates manually (e.g. Help > Check for Updates).  Instead of just saying "There are no updates available", say that there is a new beta version, or add a checkbox there.

Last night, I joked that anyone who clicks "Check for Updates" 10 times in a week should automatically be moved to the beta channel.
Comment 2 Jesse Ruderman 2009-07-17 11:40:13 PDT
Fixing this would make it easier for non-English users to find out about betas.  Having more non-English beta users could have prevented the recent 0-day (see bug 503286 comment 24).
Comment 3 Philip Chee 2009-11-17 16:50:48 PST
FYI there is the Update Channel Selector extension https://addons.mozilla.org/en-US/firefox/addon/6263 by Mossop.
Comment 4 Robert Strong [:rstrong] (use needinfo to contact me) 2009-11-17 16:51:57 PST
yep... he sits about 10 feet from me. ;)
Comment 5 Robert Strong [:rstrong] (use needinfo to contact me) 2010-05-22 13:56:25 PDT
*** Bug 567563 has been marked as a duplicate of this bug. ***
Comment 6 Robert Strong [:rstrong] (use needinfo to contact me) 2011-04-20 15:45:35 PDT

*** This bug has been marked as a duplicate of bug 642765 ***

Note You need to log in before you can comment on or make changes to this bug.