Click on a Download Link does not download the file and does nothing

NEW
Unassigned

Status

()

P4
normal
11 years ago
5 years ago

People

(Reporter: cbook, Unassigned)

Tracking

({dogfood, regression})

Trunk
x86
Mac OS X
dogfood, regression
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
Created attachment 295266 [details]
my downloads sql file

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3pre) Gecko/2008010104 Minefield/3.0b3pre

Steps to reproduce:
Go to www.newmixes.com and click on a download link - some data is transfered according to the status bar but when you check the download manager, no active download is running. 

Only right mouse click -> save as .... is working

Also reproduced when i click on ftp://ftp.mozilla.org/pub/firefox/releases/2.0.0.11/mac/en-US/Firefox%202.0.0.11.dmg in a other application window like a adium im window- a new blank window opens and there is the text "starting ftp transaction" in the status bar, but no download is started.
Also seen in bug 410131 comment 15... DTrace was showing data written to the temporary file (/tmp/mumble.exe.part), but DM never opened or showed the download. Also seemed that the download never completed, in that the .part file never got moved to ~/Desktop/mumble.exe.
This is pretty serious (at least I know that my patch in Bug 410131 didn't cause this).  Do we have any idea why this is acting the way it is?  Did this ever work properly on trunk (I'm starting to suspect not)?
Flags: blocking-firefox3?
(In reply to comment #2)
> This is pretty serious (at least I know that my patch in Bug 410131 didn't
> cause this).  Do we have any idea why this is acting the way it is?  Did this
> ever work properly on trunk (I'm starting to suspect not)?

I'm not sure; I haven't seen this type of bustage before, and don't now, even with Tomcat's downloads.sqlite imported into my profile; whatever it is, seems like it's not a corrupt downloads.sqlite file.  Very bad, all the same.  I even changed my settings to match Tomcat's, which I believe were A) automatically show the Downloads window when downloading, and B) to save to Desktop
Duplicate of this bug: 410805
I can't reproduce this problem on the latest nightly with Tomcat's downloads.sqlite file on either Mac or Linux.  In both cases, after installing downloads.sqlite into my profile and starting Firefox, I get an alert message about a failure to save a file, which folks tell me is a different bug, but Firefox otherwise starts up fine, and when I go to www.newmixes.com and click a download link, Firefox prompts me for what to do with the file, and if I tell it to save the file, it downloads the file and saves it successfully, displaying progress in the Downloads dialog.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008010404 Minefield/3.0b3pre ID:2008010404

I've seen this profile, downloading files from http://hourly-archive.localgho.st/ using right click > save as.. In this case, sometimes nothing seems to happen... I am never prompted with a Save As dialog.. I will investigate better STR and perhaps a range in 24hours at least.

Comment 7

11 years ago
some new error i've been notice.
i requested to download the latest flash plugin from adobe site.
and when i tried to download as usual nothing spiceal happened...
so i tried to do the "save target as.." thing ( i dont remember the last time i've tried it before) and i get an error when i pressed "save":
"you cant save c:\documents and settings........flash_player.exe cause you can't or not allowed folder index.
change folder properties and then try again, or save in other location"
(translatef from my heb version of firefox)
and of curse when i seleted another location nothing diffrent.
this is the link to download:
http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash
thanks
Keywords: dogfood, regression
Priority: -- → P1
Target Milestone: --- → Firefox 3 M11
(Reporter)

Comment 8

11 years ago
Here is some Debug Output i have with a new build: 

FG: isPreferred(application/octet-stream,[object Object])
FG: _shouldIntercept(application/octet-stream)
FG: doContent application/octet-stream http://www.eight.uk.to/pedro_enrique_puentes-transitions-sat-01-27-2008-newmixes.mp3
WARNING: refusing to set request header: file /debug/mozilla/content/base/src/nsXMLHttpRequest.cpp, line 2183
WARNING: refusing to set request header: file /debug/mozilla/content/base/src/nsXMLHttpRequest.cpp, line 2183
WARNING: refusing to set request header: file /debug/mozilla/content/base/src/nsXMLHttpRequest.cpp, line 2183
(Reporter)

Comment 9

11 years ago
Note: on a optimized build nothing happens and then download manager still does nothing. With the Debug Build a x11 window open AND a kind of text download manager is displayed in curl :

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
....
sdwilsh, how reproducable is this? I'm pretty sure we'd have heard more if we totally broke downloading!
Flags: blocking-firefox3? → blocking-firefox3+
gavin and I had it reproducible yesterday, and now I can't get it at all today...
Moving to beta4 for now, as it's not clear what's causing this or how many people it affects. Feel free to move back if something changes about that.
Target Milestone: Firefox 3 beta3 → Firefox 3 beta4
(Reporter)

Comment 13

11 years ago
After talking with Shawn we think its more a File Handling Problem then a Problem with the Download Manager. CC'ing dmose
Component: Download Manager → File Handling
QA Contact: download.manager → file.handling
(Reporter)

Comment 14

11 years ago
Created attachment 300769 [details]
mimetype.rdf of the problem profile
The important bit to note here is that a debug build actually opened curl for Tomcat.  An opt build actually does nothing however.
Attachment #300769 - Attachment mime type: application/rdf+xml → text/plain
No way to get it reproduced with the attached files. Tomcat, what happens for you when you create a new profile and copy the two files (downloads.sqlite and mimetypes.rdf) into that new profile? Is it reproducable? If yes could you send us please the complete profile? Otherwise can you reproduce it on OS X 10.4.11?
Priority: P1 → P3
Target Milestone: Firefox 3 beta4 → Firefox 3
Priority: P3 → P4
Not blocking on this bug for final ship. Would take a safe enough patch if one comes through.
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
I believe I have the same issue here: http://musicbrainz.org/ftpmirror/pub/musicbrainz/picard/picard-setup-0.10.0rc1.exe. I first saw this bug in Firefox 3 RC1 and I installed and checked it in RC2 also. I checked that this page works perfectly in Firefox 2.0.0.14. Neither the automatic download nor the manual link work in 3.0. Copying the address of the link to the address bar does trigger the download, though.

Firefox 3.0 is on a Windows XP SP3 machine, I checked Firefox 2 on Windows XP SP2.
(could someone confirm me this is indeed the same issue or if I should enter a separate bug)
Frederic, could you please try to reproduce it with a fresh profile? I cannot see with my builds. If it will be reproducible we are interested in getting the profile data.
With an empty profile it works. Sorry for the false report.
(In reply to comment #21)
> With an empty profile it works. Sorry for the false report.

Then please copy the data of your affected profile into the new one. Try to start in Safe Mode and check if it still happens. If yes, try to delete files from the profile directory until this issue isn't visible anymore. You should start with the downloads.sqlite file. Perhaps it is broken.
No need: I found what was causing the issue: a problem with FlashGot. I posted the issue on FlashGot's thread.
BTW, thanks for the help, Henrik!

Comment 25

11 years ago
i'm not sure this problem has any relate with flash got cause i have it also and i didnt use or installed this software in my computer...

sorry if my note is not related but i wrote it base on the previouse message said "ausing the issue: a problem with FlashGot"

thanks
(In reply to comment #25)
> i'm not sure this problem has any relate with flash got cause i have it also
> and i didnt use or installed this software in my computer...

Actually, my problem was not related to the original issue (I am almost sure since removing FlashGot solves the issue for me). But your problem may be related to the original issue. So I was OT but you maybe you are not ;-)
Netanel, please check my comment 22 and do the same steps. If you could give us some more information it would be very helpful to solve this bug.

Comment 28

11 years ago
(In reply to comment #27)
> Netanel, please check my comment 22 and do the same steps. If you could give us
> some more information it would be very helpful to solve this bug.
> 

i want to must make sure you know few more details.

i CAN download files in firefox, but not all the files.

for example, when i have a direct link to the file, or even downloading from download.com - its not work:
'opening...' you chosee to open.. which is... from... would you like to save this file? save / cancel. and of course when i press on 'save' it does nothing

when i use sites like Rapidshare filefactory or something similar - it works.
and it opened me a diffrent window:
'opening...'
you chose to open... which is... from... what firefox should do with the file? open it using... save it... do it automaticly next time for that files. ok, cancel.

so far for that thing, next thing i want to say that i've tried to do that in safe mode - no change.

i've tried to create new profile - no change.

now, for you request... i don't understand what exact you want me to do.

as far as i know deleting my profile files causes my addons to remove, reset my settings, and i dont remember what else...
and because firefox makes me so much trouble in the last time espicelly  slowness even the firefox it self... so if it really causes this thing i wont be able to help you...

Nati

Comment 29

11 years ago
I encountered the same problem in RC2 running on WXPSP2. Clicking a direct download link does not trigger the start of download manager. Copying the download link into the address bar or "saving the target as" works just fine. I don't have FlashGot installed, nor any other external download manager. 

Please let me know what additional information are neccessary to report. 
(In reply to comment #29)
> Please let me know what additional information are neccessary to report. 

You should also have a look at my comment 22. Probably you have the chance to find the affected files.

Comment 31

11 years ago
(In reply to comment #30)
> (In reply to comment #29)
> > Please let me know what additional information are neccessary to report. 
> 
> You should also have a look at my comment 22. Probably you have the chance to
> find the affected files.
> 

I started in the save mode and it works just fine. I tried to search for the "downloads.sqlite file" like you indicated in the comment 22, but with no results. Can you help me to locate it?
(In reply to comment #31)
> I started in the save mode and it works just fine. I tried to search for the
> "downloads.sqlite file" like you indicated in the comment 22, but with no
> results. Can you help me to locate it?

If it's working fine in Safe Mode, you should disable each installed extension step by step to find the add-on which causes this issue. Would be good to know which other add-ons are causing such an issue. Btw. the downloads.sqlite file is located within your profile folder:

http://support.mozilla.com/en-US/kb/profile#How_to_find_your_profile

Comment 33

11 years ago
Henrik, 

thank you for the provided information. The link was extremly helpfull. I did as you suggested: I disabled one extension after another and found out, that it was "Duplicate Tab v.1.0.1" which was causing the trouble. 
My and Martin's issues give me an idea: even more important than installing the last nightly build (which may be dangerous if done by someone who doesn't know what he is doing), you should request to disable all extensions and check if the bug is still there. This is easy to do (much easier IMO than creating an empty profile).

Comment 35

11 years ago
Hello, I made an update, and the problem still the same!
I'm now using FF 3 and the problem is not solved....
I guess its something related to the addons... else, what can cause this problem to stay in the new version?

there is a small change.
in the previouse version, it shows me some little window about downloading...
not it does nothing.

My addons:
AdBlock Plus 0.7.5.5
AVG Safe Search - not working
Download Accelerator Plus Integration - 8.0.6.5
HideIP - 1.0
IDM CC - 5.3
NoScript - 1.6.9.3
OpenSearchFox - 0.1.5
Personas for Firefox - 0.9.2
SafeCache - 0.9 - Not working
SafeHistory - 0.8 - Not working
TrackMeNot - 0.5.32 - Not working

My FF language is Hebrew.


Nati
(In reply to comment #35)
> there is a small change.
> in the previouse version, it shows me some little window about downloading...
> not it does nothing.
Could you attach a screenshot of the window you see please?

> Download Accelerator Plus Integration - 8.0.6.5
> IDM CC - 5.3
Could you please try to disable those and see if the problem still persists?

Also, IDC CC is at version 5.6 (https://addons.mozilla.org/en-US/firefox/addon/6973)

Comment 37

11 years ago
(In reply to comment #36)
> Could you attach a screenshot of the window you see please?

> > Download Accelerator Plus Integration - 8.0.6.5
> > IDM CC - 5.3
> Could you please try to disable those and see if the problem still persists?

ok.
until now, when i tried to download, in ff3 i doesn't have any window...
so, i disable those two... and the window back...

and i'll upload it now.

is it necessary to made update?
No, seems to me that one of those two is causing your problems.  You'll have to contact the right author.

Comment 39

11 years ago
Created attachment 326077 [details]
the little saving window...

sorry for taking me time for that...

Comment 40

10 years ago
I think I'm having the same problem.

I try to open the download link in a page like this: http://www.mininova.org/tor/1356067. On windows XP SP3, firefox 3.0.1 to 3.
It's happen in a lot of site, with me, In home computer and work computer.
And, If it's help to, the samething happens in the search bug engine: https://bugzilla.mozilla.org/query.cgi (it's I only had tested in 3.0.3), I had tried to find this bug in firefox using the download tag, but with no sucess, then I open in Internet Explorer, and works good.

Sorry if I did something wrong, but is my first try-to-report-bug.

thx.

Comment 41

10 years ago
I forgot to say, sorry, if I click with the middle button (button 3), the download starts.
Orlando, thanks for your report. Could you please have a look inside the options if there is any action associated to the "TORRENT File" file type under applications? It looks like there is probably set a wrong or non-existing application as default handler.

Comment 43

9 years ago
this same thing happened to me after I upgraded hard disks and disconnected one
of my drives (actually, I lost the partition).  it turns out that downloading
is dependent upon the default download directory, which I had set to be
F:\somethingorother. that drive is no longer there.  

there is a bug in firefox that completely disables downloads (already reported
in bug 454063) if that default download folder is inaccessable.  so go and set
it to something valid and see what happens.  worked for me.

Comment 44

9 years ago
sorry mac users, that last comment was for the PC, however, this bug mention may still be applicable.  try and see what happens.  hope it helps.

Comment 45

8 years ago
I have an issue that if a link to a download is clicked and 'Save As' is chosen in the Open_With/Save_As dialog that opens, once chosen, the browse-to window that then opens loses focus, so the Save button is not highlighted as default. If one presses Enter again (as would be expected if 'Save' were highlighted=enabled), then this instead re-activates the Download so a second window opens causing the download protocol to repeat over and over on ever press of Enter, instead of Confirming Save in the browsed-to location

Derek Williams.
Carsten/Tomcat: Is this still a problem ?
Target Milestone: Firefox 3 → ---
You need to log in before you can comment on or make changes to this bug.