chatzilla doesn't display correct nickname after change

RESOLVED WORKSFORME

Status

Other Applications
ChatZilla
P3
normal
RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: David Krause, Assigned: Robert Ginda)

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Overview Description:
When you change your nick in chatzilla, the change is passed to the server
properly but is not changed in the ui on the client.

Steps to Reproduce:
1) Start chatzilla
2) Enter a nick
3) Change your nick
4) Say something

Actual Results:
The ui is never update to reflect you new nick. (see screenshot)

Expected Results:
The nick on the ui should change to match the one on the server.

Reproducibility:
three times so far

Build Date & Platform Bug Found:
linux i686 2000053019

Additional Builds and Platforms Tested On:
none

Additional Information:
this is a similar but different from bug 26696
(Reporter)

Comment 1

18 years ago
Created attachment 9371 [details]
screenshot
(Assignee)

Comment 2

18 years ago
mass accepting chatzilla bugs and marking "future"
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 3

18 years ago
*MASS SPAM*

Changing QA contact on all open or unverified ChatZilla bugs to me, David
Krause, as I am now the QA contact for this component.
QA Contact: rginda → David

Comment 4

18 years ago
Just for the record I'm not seeing this on win32 (yes I know its filed against
linux os).

David could you confirm this is still happening on linux ?

Comment 5

18 years ago
It's still happening on linux as of today's build.  You have to close the
chatzilla window (which leaves the channel) then reopen it to get it to show
your nick.

Advice, don't ever join a channel initially with a long or silly nickname (akk
was taken due to a chatzilla that crashed and didn't clear the name from the
channel, so I logged in with akkWhyIsThereAnotherAkkHere and got stuck seeing
that for every comment I made :-)

Comment 6

17 years ago
This seems to have gotten fixed somewhere along the way.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.