Form controls ( radio buttons and checkboxes ) are printed too small to be legible

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Andy Boze, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008010302 SeaMonkey/2.0a1pre Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008010302 SeaMonkey/2.0a1pre

Radio buttons and checkboxes look fine in a Web page, but in Print Preview and on the printed page they are too small to be legible.

Reproducible: Always

Steps to Reproduce:
1.Look at http://www.456bereastreet.com/lab/form_controls/checkboxes/ and http://www.456bereastreet.com/lab/form_controls/radio_buttons/
2.Display each page in Print Preview and print each page.
3.
Actual Results:  
The radio buttons and checkboxes are much smaller than they appear in the browser.

Expected Results:  
Radio buttons and check boxes should be approximately the same size when printed as they are in the browser.

The radio buttons and checkboxes print at the correct size in SM 1.1.7.
Can you reproduce with current SeaMonkey v2.0a1pre ?
(If yes, could you try current Trunk Firefox too ?)
Keywords: regression
Version: unspecified → Trunk
(Reporter)

Comment 2

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9pre) Gecko/2008050602 SeaMonkey/2.0a1pre

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050606 Minefield/3.0pre

Check boxes and radio buttons are larger than when I submitted the bug report, and they are now legible on the printed page. I don't know whether it should still be considered a bug, though, since the printed check boxes and radio buttons are still smaller than they appear on screen. Compared to the font size, the on-screen boxes and buttons are about twice as wide/high as their printed counterparts.

This may be intentional, since the boxes and buttons are big enough on the printed page to be seen well, and probably need to be larger on screen to make it easier to click on them.
(In reply to comment #2)
> This may be intentional, since the boxes and buttons are big enough on the
> printed page to be seen well, and probably need to be larger on screen to make
> it easier to click on them.

I'm not sure that's the case -- they appear larger on the print preview for me!
For me, with WinXP and the latest release of SeaMonkey 2.0, checkboxes have about the same size in the browser, print preview and print result. Maybe a little bigger in the latter two. Anyway, marking WFM since at least for me they're definitely not too small. Please reopen only if you can reproduce the problem with SeaMonkey 2.0 or later.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.