Password manager notification bar appears in wrong window

RESOLVED INVALID

Status

()

Toolkit
Password Manager
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: José Jeria, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Created attachment 295344 [details]
Don't open this directly, used by the testcase

Build Id: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b3pre) Gecko/2008010104 Minefield/3.0b3pre

Steps to reproduce:
1. Load "Testcase"
2. Click on launch
3. Click "Submit Query"

Notice that the password notification bar appears in the main window. The popup used in the testcase is not so big, but the user doesn't see the notification bar if the popup bigger.

We have built a web application that launches in a big popup and the user does not see the password notification bar until he closes the popup. This leads to confusion.
(Reporter)

Comment 1

10 years ago
Created attachment 295345 [details]
Testcase
(Reporter)

Updated

10 years ago
OS: Windows 2000 → All
Hardware: PC → All
This was intentional, iirc. See http://lxr.mozilla.org/seamonkey/source/toolkit/components/passwordmgr/src/nsLoginManagerPrompter.js#565 . Perhaps we need to adjust that code to better detect "real" closing popups, or remove it.
Bug 403193 is one improvement, but doesn't change how the testcase here works.

I'm closing as INVALID since this is working as designed.

Is this a problem you ran into in the real-world (well, real-web :)?
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> Is this a problem you ran into in the real-world (well, real-web :)?

We have developed some intranet apps where we see this issue. Each app is opened in a large popup window and the users don't see the notification.

(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.