The Firefox beta 1 and 2, address bar thus not work.

VERIFIED WORKSFORME

Status

()

Firefox
Toolbars and Customization
--
major
VERIFIED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Boulay Desjardins, Jean-Nicolas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: http://www.mozilla.com/en-US/products/download.html?product=firefox-3.0b2&os=win&lang=en-US

The link I gave you has a image that shows you the bug in action... If you look carefully you will see that the address bar says google.com, normaly if I had tipe google.com, it would of change to http://google.ca/... The other thing is that the address bar thus not change wan I click a link or change page, it just keeps the first address I wrote...

The other problem is the back and fowared button that stay gray and don't work, even the refresh button dose not work its like the whole toolbar is jam for some reason.

I have tried to update, re-install... Nothing works, also when I try to update Firefox 3 beta 2 it sends me a error.

I am using a HP latop, with Windows Vista Ult. I have to say it works very well on XP but Vista it is just useless.

I hope I gave enough details, if not tell me what other information you would like me to had. And also if you want me to do a little video of the bug in action just ask.  

Reproducible: Always

Steps to Reproduce:
1.I start Firefox.
2.I go to any website.
3.From the beginning the back and forward button don't work and the address bar stays the same.
Actual Results:  
From the beginning the back and forward and the address bar don't work. Its not a bug that happens after I do some thing its like that all the time whatever I do.

Expected Results:  
Back and forward and the address bar to work.

I did not test it in windows vista safe mode... But even then you still have the bug. I wish I could give more information. I personally think that it could be Xul thats freaking out for some reason, I not sure of what I am saying but you never now.

I am using AVG Free version has a anti virus. 

Windows edition:

Windows Vista Ultimate

System:

Manufacturer: Hewlett-Packard
Model: HP Pavilion dv9000
Rating: 4,3 Windows Experience Index: Unrated
Processor: Intel(R) Core(TM)2 CPU T5500 @ 1.66GHz 1,67 GHz
Memory (RAM): 2046 MB
System type: 64-bit Operating System

If there is any other info, please ask.
This works for me using Firefox 2.0.0.11 and a new profile on Windows XP.
You could try out the following trouble-shooting options:

- Firefox's safe-mode to exclude extension/theme problems (is not the same as system safe-mode)
- a new profile
- a reinstall in a new empty folder

http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder
(Reporter)

Comment 2

11 years ago
Ok I tried Safe mode it thus not change any thing.

Here is a video of the problem that I have with Firefox 3 Beta 2.

First I show that its impossible to update it... After I show how the back and forward button don't work.

http://jeannicolas.com/firefox/firefox.html
Have you used the same Firefox user profile between both 2.0.0.11 and Firefox 3 beta 1/2?
(Reporter)

Comment 4

11 years ago
Firefox 2.0.0.11 works...

Its Firefox 3 beta 1 and 2 that have the buggy address bar.

I have Firefox 2 and Firefox 3 beta 2 I remove beta 1.

It seems I have one profile:

C:\Users\jnbdz\AppData\Roaming\Mozilla\Firefox\Profiles\in1ueurg.default

Thats the only folder in Profiles.

(Reporter)

Comment 5

11 years ago
I just created a new profile for Fx 3 beta 2 and it stop bugging. But I don't understand why it does not create its own profile... And also why I did not experience this in Windows XP pro.
Sorry, the build was even mentioned in your summary. :)
Maybe a corruption of the places.sqlite file (Bug 408443)?
Possible that you got corrupted sqlite files because you used an alpha with this Version.
Moving the sqlite files from your broken profile away should fix this.
(Reporter)

Comment 9

11 years ago
I have been using Firefox 3 beta 2 with Vista for a wild now, and I did not experience any new big problems.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 10

11 years ago
I have been using Firefox 3 beta 2 with Vista for a wild now, and I did not experience any new big problems.
Resolution: WORKSFORME → FIXED
"WORKSFORME" is the correct resolution here, as nothing was actually fixed on Firefox's side.
Resolution: FIXED → WORKSFORME
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.