URLs in location bar auto-completion list are not visible

RESOLVED FIXED

Status

()

Firefox
Address Bar
--
major
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Christiaan Hofman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2008010304 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2008010304 Minefield/3.0b3pre

The URLs displayed in the auto-completion list of the location bar are not visible, they are drawn at the complete right of the list, only the first few characters are visible.

Reproducible: Always

Steps to Reproduce:
1. Type a few letters in the location bar text field
2. 
3.
Actual Results:  
The completion list pops up. It displays a list the title of the page that possibly matchs, and tat the far right only the firts 5 characters of the corresponding URLs are visible.

Expected Results:  
The URL for the match should be completely visible. Most times I type a URL, so I try to find a URL (not a mostly uninformative page title). 

I reported on the new completion list before. I thought it was a regression, as the URL was not easily recognizable. Now it has completely vanished. It gets worse and worse with every new beta.

Comment 1

10 years ago
For me (and most trunk users), autocomplete list items appear as two lines, with the title on the first line and the URL on the second line.  I don't know why it would look different for you.  Are you using any Firefox extensions?

Comment 2

10 years ago
The proto theme is broken according to:
http://forums.mozillazine.org/viewtopic.php?p=3204941#3204941

Comment 3

10 years ago
Created attachment 296485 [details]
Screenshot showing crop problem on takebacktheweb.org theme

Here's what it looks like for me on the GrApple theme from takebacktheweb.org. This doesn't seem to be a Proto problem.

Comment 4

10 years ago
Try the default theme?  Maybe there was a trunk change and *all* third-party themes need to be updated for it.

Comment 5

10 years ago
Created attachment 296486 [details]
Screenshot showing menu on default theme

Sure, here's another shot. It has the two-line look again. Interesting. I'm going back to GrApple because I can't stand the default theme personally but hopefully it won't take too long to figure out what's gone wrong here. I use titles as much as I use URLs to search, so I would like to see this resolved. I used to see the dropdown on two lines with GrApple -- I can't say just when it changed on me but it was within the last week.

Comment 6

10 years ago
Created attachment 296487 [details]
Shot showing updated GrApple theme with working search list

I just found out that GrApple went up to 0.8.9.4 when I wasn't looking, and I never got an update notification, so I manually updated and the menu works again. Here's another shot. It's worth consideration as a workaround until the Proto theme is working again. This does indeed then look like a problem with Proto after all -- I retract my initial guess.
Attachment #296485 - Attachment is obsolete: true

Comment 7

10 years ago
This was fixed with a Proto update a while back wasn't it?
(Reporter)

Comment 8

10 years ago
Yes, this one is fixed now.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.