Some patches from pkgsrc

RESOLVED WONTFIX

Status

SeaMonkey
General
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: Roland Illig, Unassigned)

Tracking

({meta})

SeaMonkey 1.1 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.8.1.8) Gecko/20071101 SeaMonkey/1.1.5

Pkgsrc is a package management system that doesn't like to patch the original programs much. Currently we have more than 60 patches for seamonkey. Please have a look at them and decide whether you can apply them. They are at:

http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/www/seamonkey/patches/

patch-d* should be easy. They are required for building seamonkey on DragonFly BSD.

patch-ec is also trivial. The test(1) utility need not know the == operator. (See http://www.opengroup.org/onlinepubs/000095399/utilities/test.html for details.)

I cannot tell you anything about the other patches, since I didn't write them. If you have questions, please ask on the tech-pkg@NetBSD.org mailing list.

Roland

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Please open a separate bug for each issue, with a descriptive "Summary", then you can set each of these new bugs as "blocking" this one, "accept" each detail bug and request, in turn (and again for each bug) one of more of 1) review, 2) superreview, 3) approval, depending on which parts of the code are touched at which time.
Keywords: meta
Version: unspecified → SeaMonkey 1.1 Branch

Comment 2

9 years ago
Now that trunk is on 1.9.1/1.9.2 those patches are really bit rotted. Besides the 1.8.1 branch is definitely not taking anything except for critical security patches. They will need to provide patches against our trunk Mercurial repositories. AND file one bug per patch/issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.