8-bit filter key does not filter incoming msgs

VERIFIED FIXED in M18

Status

MailNews Core
Filters
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: Alec Flett)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
** Observed with 5/31/2000 Win32 build **

This bug is probably directly related to Bug 40346, but 
when we input filter key like:

日本語

Try this in the subject line in sedning a message and
also in the filter key to move the relevant message to
another folder. It does not work.

Comment 1

18 years ago
i don't see filter working at all: in my case it doesn't run any data 
(regardless of bits : neither us-ascii nor non-ascii)
(Reporter)

Comment 2

18 years ago
I understand from mscott who is sitting next to me now
that Alec is not claiming that this feature is working
officially. That is why the menu is prefaced with a dot.

Let's keep this bug as a reminder to alecf that he needs to
think about i18n issue as he goes along. 
(Assignee)

Comment 3

18 years ago
I'm doing the frontend, but I realize that much of the backend is not i18n 
friendly... but 7-bit clean filters should be working.
Status: NEW → ASSIGNED

Updated

18 years ago
QA Contact: lchiang → laurel

Comment 4

18 years ago
marking M17.  Is this bienvenu's?
Target Milestone: --- → M17
(Reporter)

Comment 5

18 years ago
*** Bug 42064 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 6

18 years ago
Added laurel to CC.

Comment 7

18 years ago
Alec, is this something we need to fix for beta3?
(Assignee)

Comment 8

18 years ago
yes!
Keywords: nsbeta3
(Reporter)

Comment 9

18 years ago
What Beta3?
Filtering with internaitonal key/terms is part of
Beta 2 requirements.

Comment 10

18 years ago
moving to M18.
Target Milestone: M17 → M18
(Assignee)

Updated

18 years ago
Component: Mail Back End → Filters
(Reporter)

Comment 11

18 years ago
Laurel, if you don't mind I want to take this 
for myself.
QA Contact: laurel → momoi

Comment 12

18 years ago
*** Bug 44373 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
*** Bug 45197 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
It is working on my machine for Japanese subject (win32 used debug build 
today's pull). The local search fix might have fixed this too. Could someone in 
IQA verify if it's really fixed?
(Reporter)

Comment 15

18 years ago
Xianglan, can you help with this? I've got other tasks today.
Thanks.
QA Contact: momoi → ji

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 16

18 years ago
Verified with 2000-07-25-08 win32 and linux build. The message filter with a 
non-ASCII name containing a non-ASCII filter key is working for both IMAP and 
POP mails. 

Comment 17

18 years ago
Marked it as verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.