browser crashes with seg fault when attempting to import bookmarks

CLOSED WORKSFORME

Status

SeaMonkey
Bookmarks & History
P3
critical
CLOSED WORKSFORME
18 years ago
13 years ago

People

(Reporter: O'Shaughnessy Evans, Assigned: Steve Lamm)

Tracking

({crash})

Trunk
Sun
Solaris
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (X11; I; SunOS 5.7 sun4u; Nav)
BuildID:    2000053021

I run mozilla and try to import a bookmarks file.  I don't even
get a dialog from "Import Bookmarks...." -- the browser crashes
immediately after selecting that option from the "File" dropdown.
All the Mozilla windows disappear and the output terminal says
"Segmentation Fault".

Reproducible: Always
Steps to Reproduce:
1. Run the "mozilla" script from the nightly build distribution.
2. Open Bookmarks -> Manage Bookmarks....
3. In the "Bookmarks" dialog, open File -> Import Bookmarks....

Actual Results:  The browser crashes immediately.

Expected Results:  It should have allowed me to select a file to import and then
loaded the contents into my mozilla bookmarks.

Here's the output from the terminal where mozilla was run.  All that I did was
start up mozilla, Manage Bookmarks, and then try to Import Bookmarks:

 ./mozilla
.//run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=/usr/local/lib/mozilla/package
 
LD_LIBRARY_PATH=/usr/local/lib/mozilla/package:/usr/local/lib:/usr/lib:/usr/dt/lib:/usr/openwin/lib:/usr/ucblib
     LIBRARY_PATH=/usr/local/lib/mozilla/package
       SHLIB_PATH=/usr/local/lib/mozilla/package
          LIBPATH=/usr/local/lib/mozilla/package
       ADDON_PATH=/usr/local/lib/mozilla/package
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
Profile Manager : Profile Wizard and Manager activites : Begin
Profile Manager : Command Line Options : Begin
Profile Manager : Command Line Options : End
ProfileManager : GetProfileDir
ProfileManager : GetProfileDir
Profile Manager : Profile Wizard and Manager activites : End
WEBSHELL+ = 1
WEBSHELL+ = 2
CSSLoaderImpl::LoadAgentSheet: Load of URL
'file:///home/shaug/.mozilla/mozProfile/chrome/user.css' failed.  Error code:
16389
assuming d&d is off for Personal Toolbar
WEBSHELL+ = 3
WEBSHELL+ = 4
Setting content window
*** Pulling out the charset
Loading page specified via openDialog
in SetSecurityButton
Warning - table cell content max element height 300 greater than desired height
278
Warning - table cell content max element height 300 greater than desired height
278
Warning - table cell content max element height 300 greater than desired height
278
Warning - table cell content max element height 300 greater than desired height
278
Warning - table cell content max element height 300 greater than desired height
278
Warning - table cell content max element height 300 greater than desired height
278
Document: Done (1.524 secs)
*** check number of frames in content area 
Document http://zero/ loaded successfully
we don't handle eBorderStyle_close yet... please fix me
WEBSHELL+ = 5
TOP LEVEL bookmarks window got a dragHTML Files (*.htm; *.html) *.htm; *.html
Segmentation Fault

Comment 1

18 years ago
Adding crash to keyword field.
Keywords: crash

Comment 2

18 years ago
With mozilla-sparc-sun-solaris2.6.tar.gz, build 2000062921, I could import my
netscape bookmarks without problems. No crash. Recommend worksforme.

Comment 3

18 years ago
I concur as i've seen no problem with my 2000070509 (linux) build either.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 4

18 years ago
marking VERIFIED
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

16 years ago
since i opened this bug (2 years ago!) and just realized that it wasn't marked
as closed, i figured i would mark it so.  i hope that's okay.
Status: VERIFIED → CLOSED

Comment 6

16 years ago
in the future, 'VERIFIED -whatever' is the final stage in the bug life cycle
that any of us would ever be concerned with. Don't mark them 'CLOSED'. I'll
leave this alone as it will just generate uncessary mail to fix it back.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.