"(missing)" not displayed when font with differing Carbon/Cocoa names is selected using the Cocoa picker

RESOLVED WONTFIX

Status

Camino Graveyard
Preferences
--
minor
RESOLVED WONTFIX
10 years ago
10 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Unassigned)

Tracking

1.8 Branch
PowerPC
Mac OS X

Details

STR:

1. Select a font that has different Carbon and Cocoa names (e.g., any of the Japanese fonts) using the normal UI (Cocoa font panel)

2. Observe the font is not listed as "(missing)" even though Gecko will not use that font.

Ideally, we'd want to just make the Camino UI correctly translate between the Cocoa font panel and Gecko's crazy font name needs and only use "(missing)" for fonts that are truly not found on the user's machine, but in the interim we should probably do something to indicate to the user he's selecting a font Gecko won't use.

Comment 1

10 years ago
Do we want to just punt on this, or are we planning on doing a 1.7? I assume this is fine on trunk, since it's filed against the 1.8 branch only.
Similar (but not the same) issues with the trunk should be covered by bug 391076.  It's probably not worth fixing this on the branch at this point.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.